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Chapter
46 The SDL Type Viewer
The Type Viewer shows SDL-92 types and type instances in the cur-
rent system and how they relate to each other. 

This chapter contains a reference manual to the Type Viewer; the 
functionality it provides, its menus, windows and symbols.
gic Tau 4.5 User’s Manual ,um-st1 2001



Chapter 46 The SDL Type Viewer 
Objects and Windows

Objects and Attributes
An object in the Type Viewer is either a type or an instance of a type. 
Both of these may be referred to as a type in the Type Viewer and in this 
chapter. For each type object, the following attributes can be presented:

• A graphical symbol to identify the type of diagram. The symbols are 
identical to the icons used in the Organizer’s Main window (see 
“Icon Types” on page 50 in chapter 2, The Organizer). The symbol 
is always shown.

• The type identifier, in the form
<virtuality> <diagram type> <object type>, where:

– <virtuality> may be either 
Virtual, Redefined or Finalized

– <diagram type> may be either 
System, Block, Service or Process

– <object type> may be either 
Type or Instance

• The name of the type or instance

• The complete qualifier, in text form.

You can hide or show each of the last three text items. By default, the 
type identifier and the type name is shown.

You can open an SDL Editor by double clicking on a symbol in the 
Type Viewer. If a type symbol is double clicked, an SDL Editor is 
opened with that type diagram. If an instance symbol is double clicked, 
an SDL Editor is opened with the diagram that contains the instance.

Type Viewer Windows
The Type Viewer has two windows, the list window and the Tree win-
dow, which present the type information in the system in two different 
ways. The main window lists the type objects without showing inherit-
ance or redefinition relations between them, whereas the Tree window 
shows such relations for a type object in a tree form. Both windows can 
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 Objects and Windows
display all of the object attributes above, but in somewhat different 
ways.

The Main window is opened when the Type Viewer is started, whereas 
the Tree window is not opened initially. The general characteristics of 
these windows are described in chapter 1, User Interface and Basic Op-
erations.

Updating the Type Viewer
When the Type Viewer is started, it extracts type information from the 
current system. If, for any reason, there are problems extracting type in-
formation, you are warned in a dialog and details can be found in the 
Organizer log window. You may update the information in the Type 
Viewer at any time, with the Update command.

The Type Viewer obtains the information about what types are defined 
in the SDL scope from the Information Server. The Information Server 
updates its contents each time an SDL diagram is saved. When the di-
agram is saved, the Analyzer is invoked and produces a mirrored image 
which is an SDL/PR description of the SDL/GR diagram. That informa-
tion is then loaded into the Information Server which serves the Type 
Viewer with information upon request. All of this is done automatically 
without the user having to bother about performing any actions.

Error Reporting

Any errors are appended to the Organizer log window. For a reference 
to error messages that may be produced by the Information Server, see 
“Information Server Error Messages” on page 906 in chapter 18, The 
Information Server.

Note:

In order to extract signal information from a diagram, the diagram 
needs to be syntactically correct in the sense that SDL/PR code can 
be generated from the SDL/GR diagram without encountering er-
rors. 
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Chapter 46 The SDL Type Viewer 
Main Window

The Drawing Area
The main window’s drawing area contains a simple line-oriented list of 
all types in the current SDL system. No inheritance or redefinition rela-
tions are shown. The object attributes are listed in the following way 
(see Figure 433):

The qualifier is displayed within double angle brackets on a single text 
line, with slashes separating the path items.

In the list, the type objects are sorted alphabetically according to the di-
agram type, object type and type name, i.e. all objects of the same dia-
gram type are grouped together.

When you select a type or instance in the main window, the Tree win-
dow is updated and displays the relation trees that contain the selected 
type/instance. If the Tree window has not been opened earlier in the 
same Type Viewer session, the Tree window is opened automatically.

Type identifier   Type name
<< Qualifier >>

Figure 433: Main window

Icon
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 Main Window
The Menu Bar

File Menu

The File menu contains the following menu choices:

• Update

• Print
(See “Printing from the SDL Suite” on page 307 in chapter 5, Print-
ing Documents and Diagrams.)

• Exit
(See “Exit” on page 15 in chapter 1, User Interface and Basic Op-
erations.)

Update

Updates the type list in the main window and the type trees in the Tree 
window, according to the possibly changed SDL diagrams (see “Updat-
ing the Type Viewer” on page 2003).

This command should be used whenever changes that might have an 
impact on the type inheritance are applied to any of the SDL diagrams 
contained in the diagram structure. 

View Menu

The View menu contains the following menu choices:

• Window Options
• List Options
• Symbol Options
• Set Scale

Window Options

Sets options for which parts of the main window to show. The dialog 
controls whether to show the tool bar and the status bar.

List Options

Sets options for which symbols to include in the list in the main win-
dow. The dialog controls whether to show Instance symbols (type sym-
bols are always shown).
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Chapter 46 The SDL Type Viewer 
Symbol Options

Sets options for which attributes to show for each type object in the list 
in the main window. The dialog controls whether to show the Qualifier, 
the Type identifier, and the Name of the types and instances.

Set Scale

Issues a dialog where the scale for the main window may be set.

Tools Menu

The Tools menu contains the following menu choices:

• Show Organizer
(See “Show Organizer” on page 15 in chapter 1, User Interface and 
Basic Operations.)

• Search
• Search Again
• Show in Editor
• Show Type Trees

Search

Searches for a visible text in the type list shown in the Main window.

• Search for

Specifies the text string to search for. As a special case, a GR Ref-
erence obtained from for instance an editor may also be specified.

• Ignore Case, Consider Case 

Figure 434: The Search dialog
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 Main Window
These options toggles between a case insensitive and a case sensi-
tive search. 

• Search

Starts the search and closes the dialog. The first symbol containing 
the text is selected. The search starts from the selected symbol, if 
any, or from the first symbol in the list.

If the search reaches the end of the list, you are asked whether to con-
tinue the search from the top of the list or not.

If the text cannot be found among the visible information, you are in-
formed in a confirmation dialog.

Search Again

Searches again for the same text as in the latest search. The behavior is 
the same as described in “Search” on page 2006.

Show in Editor

Shows the selected type or instance in an SDL Editor. If a type symbol 
is selected, an SDL Editor is opened with that type diagram. If an in-
stance symbol is selected, an SDL Editor is opened with the diagram 
that contains the instance.

Show Type Trees

Opens or raises the Tree window. The type or instance selected in the 
Main window becomes selected in the Tree window.
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Chapter 46 The SDL Type Viewer 
Popup Menus
The following tables lists the menu choices in the Main window popup 
menus and a reference to the corresponding menu choice in the menu 
bar.

On the Main Window Background

On a Symbol in the Main Window

Keyboard Accelerators
Apart from the general keyboard accelerators, the following accelerator 
can be used in the main window:

Search “Search” on page 2006.

Search Again “Search Again” on page 2007.

Show Type Trees “Show Type Trees” on page 2007.

Search “Search” on page 2006.

Search Again “Search Again” on page 2007.

Show in Editor “Show in Editor” on page 2007.

Show Type Trees “Show Type Trees” on page 2007.

Accelerator Reference to corresponding command

Ctrl+E “Show in Editor” on page 2007
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 Tree Window
Tree Window

The Drawing Area
The Tree window’s drawing area visualizes inheritance and redefinition 
relations between types by presenting the types and instances in a tree 
form. There are two types of trees displayed in the Tree window:

• A Redefinition tree shows virtual types, specializations based on re-
definition of the virtual types, and all instances of these types.

• An Inheritance tree shows types, specializations based on inherit-
ance and adding properties to the types, and all instances of these 
types.

The two trees for a certain type are often, but not always, identical. The 
Type Viewer supports you by checking if they are identical; if so, they 
are shown as one tree. When the Inheritance and Redefinition trees are 
different, both are shown separately. Each tree has a header identifying 
which type of tree it is.

The object attributes are listed vertically in the trees in the following 
way (see Figure 435):

The qualifier is displayed in italics in a multi-line form, with each path 
item on a separate line. No angle brackets or slashes are used.

In the tree, the type objects with the same parent are placed from left to 
right alphabetically according to the diagram type and object type. 

Icon

Type identifier
Qualifier

Type name
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Chapter 46 The SDL Type Viewer 
The Tree window is updated when the selection in the Main window is 
changed. The Tree window is updated to show the Inheritance and Re-
definition trees in the system that contain the type/instance that is select-
ed in the Main window. The first occurrence of that type/instance also 
becomes selected in the Tree window. 

It is possible to view all Inheritance and Redefinition trees in the current 
system at once in the Tree window (see “Show All Trees” on page 
2012). The trees are lined up vertically in the same drawing area.

Figure 435: Tree window
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 Tree Window
The Menu Bar

File Menu

The File menu contains the following menu choices:

• Print
(See “Printing from the SDL Suite” on page 307 in chapter 5, Print-
ing Documents and Diagrams.)

• Close
(See “Close” on page 14 in chapter 1, User Interface and Basic Op-
erations.)

View Menu

The View menu contains the following menu choices:

• Expand
• Expand Substructure
• Expand All
• Collapse
• Window Options
• Tree Options
• Symbol Options
• Show All Trees
• Set Scale

Expand

Expands the selected object one level down.

Expand Substructure

Expands the selected object as much as possible.

Expand All

Expands all visible trees as much as possible.

Collapse

Collapses the selected object, i.e. hides all child objects. If there is no 
selected object, the menu choice is named Collapse All. Collapse All 
collapses all trees in the window.
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Chapter 46 The SDL Type Viewer 
Window Options

Sets options for which parts of the Tree window to show. The dialog 
controls whether to show the tool bar and the status bar.

Tree Options

Sets options for which symbols to include in the trees in the Tree win-
dow. The dialog controls whether to show instance symbols (Type sym-
bols are always shown).

Symbol Options

Sets options for which attributes to show for each symbol in the trees in 
the Tree window. The dialog controls whether to show the Qualifier, the 
Type identifier, and the Name of the types and instances.

Show All Trees

Shows type trees for all types in the system.

Set Scale

Issues a dialog where the scale for the Tree window may be set.

Tools Menu

The Tools menu contains the following menu choices:

• Show Organizer
(See “Show Organizer” on page 15 in chapter 1, User Interface and 
Basic Operations.)

• Search
• Search Again
• Show in Editor
• Show Type Viewer

Search

Searches for a text in the type trees shown in the Tree window.
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 Tree Window
• Search for

Specifies the text string to search for. As a special case, a GR Ref-
erence obtained from for instance an editor may also be specified.

• Ignore Case, Consider Case 

These options toggles between a case insensitive and a case sensi-
tive search. 

• Search

Starts the search and closes the dialog. The first symbol containing 
the text is selected. The search starts from the selected symbol, if 
any, or from the first symbol in the first tree.

If the search reaches the end of the trees, you are asked whether to con-
tinue the search from the first tree.

If the text cannot be found, you are informed in a confirmation dialog.

Search Again

Searches again for the same text as in the latest search. The behavior is 
the same as described in “Search” on page 2012.

Show in Editor

Shows the selected type or instance in an SDL Editor. If a type symbol 
is selected, an SDL Editor is opened with that type diagram. If an in-
stance symbol is selected, an SDL Editor is opened with the diagram 
that contains the instance.

Figure 436: The Search dialog
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Chapter 46 The SDL Type Viewer 
Show Type Viewer

Raises the Type Viewer’s Main window.

Popup Menus
The following tables lists the menu choices in the Tree window popup 
menus and a reference to the corresponding menu choice in the menu 
bar.

On the Tree Window Background

On a Symbol in the Tree Window

Search “Search” on page 2012.

Search Again “Search Again” on page 2013.

Show All Trees “Show All Trees” on page 2012.

Show Type Viewer “Show Type Viewer” on page 2014.

Expand All “Expand All” on page 2011.

Collapse All Collapse all top objects in all trees.

Search “Search” on page 2012.

Search Again “Search Again” on page 2013.

Show in Editor “Show in Editor” on page 2013.

Show All Trees “Show All Trees” on page 2012.

Show Type Viewer “Show Type Viewer” on page 2014.

Expand “Expand” on page 2011.

Expand Substructure “Expand Substructure” on page 2011.

Collapse “Collapse” on page 2011.
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 Tree Window
Keyboard Accelerators
Apart from the general keyboard accelerators, the following accelerator 
can be used in the Tree window:

Accelerator Reference to corresponding command

Ctrl+E “Show in Editor” on page 2013
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