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Chapter
31 Editing TTCN Documents 

(in Windows)
In the TTCN suite, TTCN test components can be edited on table 
level as well as restructured on a hierarchical level. This chapter de-
scribes the editors and information managers in the TTCN suite in 
Windows and how to use them.

For an overview of the TTCN suite, see chapter 2, Introduction to 
the TTCN Suite (in Windows), in the TTCN Suite Getting Started.

Note: Windows version

This chapter is Windows only. The corresponding UNIX chap-
ters are chapter 25, The TTCN Browser (on UNIX) and chapter 
26, The TTCN Table Editor (on UNIX).
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Chapter 31 Editing TTCN Documents (in Windows) 
Introduction to the TTCN Suite
The TTCN suite can be used for development, specification and compi-
lation of test system components in the TTCN language. The function-
ality included will be described below.

The TTCN suite supports all of the standardized, non-compact tables 
that are defined in ISO/IEC 9646-3. The compact test case dynamic be-
haviour table (ISO/IEC 9646-3, clause C.3) and concurrent TTCN ta-
bles are also supported. The compact tables for constraints (also in An-
nex C of ISO/IEC 9646-3) are not supported.

The general user interface concepts and common menu choices in Tele-
logic Tau are described in chapter 1, User Interface and Basic Opera-
tions.

Different Views of the TTCN Document
The contents of a TTCN test suite can be viewed in the Browser, the 
Finder and the Table Editor:

• The Browser presents an overview of the TTCN tables. In the 
Browser it is possible to edit the TTCN table structure, to determine 
which parts of the test system component to view and to apply a 
number of operations on it. See “Using the Browser” on page 1237.

• The Table Editor presents TTCN tables for editing, referencing, and 
a number of table-specific operations. See “Editing Tables” on page 
1246.

• The Finder presents a non-hierarchical view of the TTCN tables. 
Subsets of the total set of tables can be extracted, sorted according 
to various rules, and a number of operations can be performed on the 
resulting set of tables. See “Finding and Sorting Tables” on page 
1260.

The Log Manager gives another view of the test suite. It presents log 
outputs from the currently loaded test system components. Information 
from various operations, such as analysis and simulation, will appear in 
the test component log in the Log Manager. See “Viewing Log Infor-
mation” on page 1257.
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Functionality to Apply on the TTCN Document

Building Test Components and Tables

• The Data Dictionary is used in conjunction with the Table Editor, 
and offers an easy way to build TTCN behavior statements from the 
declared test system components. For more information, see “Cre-
ating Behaviour Lines” on page 1253.

• SDL to TTCN Link is similar in use and appearance to the Data Dic-
tionary. It utilizes a Link executable for an SDL system to interac-
tively build the behavior of a TTCN test for that particular system. 
For more information, see chapter 36, TTCN Test Suite Generation.

• Autolink supports semi-automatic generation of TTCN test suites 
based on SDL specifications. For more information, see chapter 36, 
TTCN Test Suite Generation. The menu choice Autolink Merge in 
the File menu may be used for merging Autolink generated MP files 
into an opened test suite. 

Analyzing, Verifying and Executing a Test

• The Analyzer verifies syntactic correctness of test components. For 
more information, see chapter 32, Analyzing TTCN Documents (in 
Windows).

• The TTCN to C compiler generates C code from TTCN. For more 
information, see chapter 33, The TTCN to C Compiler (in Win-
dows).

The Generic Compiler Interpreter interface is an interface for the 
adaption of the generated code to a specific target environment. For 
more information, see chapter 37, Adaptation of Generated Code.

• The Simulator allows execution and interactive debugging of test 
systems. For more information, see chapter 34, The TTCN-SDL Co-
Simulator (in Windows).
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Starting the TTCN Suite
You can start the TTCN suite from the Organizer in the following ways:

• Select Tools > Editors > TTCN Browser in the Organizer. This will 
also add an untitled TTCN document in the Organizer.

• Double-click on a TTCN document icon already included and con-
nected in the Organizer (or select Edit from the Edit menu).

• Add a new TTCN document to the Organizer and make sure that the 
option Show in editor is checked in the Add New dialog.

• Add an existing TTCN document to the Organizer.

Figure 219:The TTCN suite is started and the Browser displays a modular test suite
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Using the Browser
When you open a TTCN document it will be displayed in the Browser. 
As the structure of TTCN is tree oriented, the Browser presents an over-
view of the test system component in tree form.

Multiple Browser views can be opened on a document and all editing 
performed in a Browser will be simultaneously reflected in the other 
opened Browser windows. 

In addition to this, you may create sub Browsers. This means that you 
restrict the view to only display a few nodes. In combination with the 
possibility to have multiple Browsers open on the same test document, 
this enables you to keep just the interesting bits of information in a cou-
ple of small Browser windows.

By using the edit operations, such as Add In and Delete, you can manip-
ulate the Browser structure to build a complete TTCN system compo-
nent. You can control the amount of information actually displayed in a 
Browser, by collapsing and expanding sub trees.

Opening the Browser and a TTCN Document
You open the Browser and a TTCN document by selecting New or Open 
from the File menu. From the File menu, you can also select the four 
most recently used files. 

To open additional Browsers for the same component:

• Make sure the Browser is active and select File > New Window.

The Browser is also opened automatically when the TTCN suite is start-
ed from the Organizer, as described in “Starting the TTCN Suite” on 
page 1236.

Hint:

If you try to open very large test suites, for example containing ex-
tensive constraint declarations, you may get an error message about 
“scanner buffer overflow”. You can solve this by setting the envi-
ronment variable ITEX_SCANNER_BUFFER_SIZE to a high val-
ue, for example 75 000 000.
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The Browser User Interface
The initial structure of a TTCN tree contains place holders for the static 
parts of the system component. These static nodes are automatically 
created by the TTCN suite whenever you create a new test system com-
ponent. What you usually do when you build a test system component 
is to add dynamic child nodes to the static nodes, and fill them with test 
specification data. Examples of static nodes are the Declarations Part 
and the Constraints Part. Examples of dynamic nodes include tables, 
groups or objects in a table (e.g. test case variables).

The Browser displays all the static nodes in the order defined in the 
TTCN standard. This ordering cannot be changed. For example, it is not 
possible to have the Constraints Part coming before the Declarations 
Part. Only the dynamic items – the tables – may be added and deleted.

Static nodes are the only nodes that can become the root of a sub Brows-
er.

Static Nodes in the Browser

Static nodes can take on four different appearances depending on the 
parse status of dynamic nodes below. Whenever you analyze a sub-tree, 
or parts of it, or edit it in a way such that the parse status of one or more 
dynamic nodes is altered, an abnormal parse status is indicated by the 
appearance of the static parent nodes.

To find a table that has to be corrected, you follow the marked nodes 
through the tree. Note that erroneous nodes have precedence over non-
parsed ones, so even a single erroneous child to a static node will make 
it red no matter how many non-analyzed nodes there are in the sub-tree.

This is an ordinary static node. All children to this node have been ana-
lyzed with status OK.

This is a static node where at least one of the dynamic nodes in the sub 
tree below has not yet been analyzed or is in need of analysis. There are 
no erroneous dynamic nodes.

This is a static node where at least one of the dynamic nodes in the sub 
tree below has been analyzed with an error or warning as result. In the 
actual view, the arrow is red for errors and purple for warnings.
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It may be that some of the static nodes will remain unused. A TTCN test 
system component is allowed to leave out the use of for example Test 
Case Variables. However, although this empty node will be displayed 
in the Browser, it will not be printed or output in the TTCN-MP format.

Dynamic Nodes in the Browser

A dynamic node is always associated with a table and can be accessed 
by the Table Editor. Two kinds of dynamic nodes can have children, 
namely multiple tables and group tables. Multiple tables look just like 
ordinary table icons, with the added feature of possible children, where-
as group tables (referred to as group nodes in the Browser) have a dif-
ferent look to distinguish them somewhat from the others.

This is a group node with all dynamic nodes in its sub tree analyzed with 
status OK.

This is a group node with a sub-tree containing at least one non-ana-
lyzed dynamic node, but no erroneous ones.

This is a group node with a sub-tree containing at least one dynamic 
node analyzed with an erroneous status or a warning. In the actual view, 
the color is red for errors and purple for warnings.

This is a dynamic node (or multi-table) that is analyzed with status OK.

This is a dynamic node that needs to be analyzed.

This is a dynamic node that has been analyzed and contains one error. 
In the actual view, the cross is red for errors and purple for warnings.
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Controlling the Nodes in the Browser
As the Browser displays the information in a TTCN document in a tree 
oriented way, it is very simple to control the amount of information that 
the you want to see at a specific moment.

Expanding and Collapsing a Node

Nodes with sub-trees are possible to expand and collapse to show or 
hide the branch below it. This works in the same way that you expand 
and collapse directory levels in the Windows Explorer by double-click-
ing.1

• The shortcut for collapse is <Left arrow> when an expanded 
node is selected.

• The shortcut for expand is <Right arrow> when a collapsed node 
is selected.

Figure 220: Different node types in a Browser

1. Note that test group nodes differ. Double-clicking a group node that is expanded 
always opens its associated table instead of collapsing it. Click on the minus sign 
to the left of the group icon instead.
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Selecting Nodes

Click a node to select it. <Ctrl>-click a node to extend the current se-
lection.

Instead of using the mouse for navigation, you can use the following 
shortcuts:

• To move the selection to the next node, use <Down Arrow>. 
• To move the selection to the previous node, use <Up Arrow>.

Renaming Dynamic Nodes

To rename a dynamic node:

• Click the name of a selected node, then type the new name and press 
<Enter>.
– You can also change the name in the table itself.

Creating a Sub Browser

To get a Browser with the full TTCN document tree, select New Win-
dow from the Window menu.

Editing the Browser Structure
The static structure is automatically generated when a TTCN document 
is first created and cannot be edited. To build an individual TTCN sys-
tem component, you need to add named tables – such as PDUs, con-
straints and behavior tables – and named objects to the multi-object ta-
bles – such as test case variables, PCOs and timers.

Use the Edit menu choices for adding, deleting, copying, pasting, etc, 
editable nodes – also called dynamic nodes – (that is, groups, tables or 
objects in a multiple object table) in the Browser. 

To create a sub Browser:

• Select Make Sub Browser from the View menu. This replaces the 
contents of the active Browser with the selected node and its sub 
tree.
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Generating the Test Suite Overview

The test suite overview is a collection of tables that contain test suite 
structure, test case index and default index. These are used for reference 
in a printed copy of the system component, as described in the TTCN 
standard. The overview will be generated the first time you print the test 
suite, export it or open the overview tables. The generation may take a 
little while, but it is only needed once for each session, as the tables are 
automatically updated when you edit the test suite.

Adding Nodes

In the case of multiple-object tables, select the node that represents 
the multiple-table. When you select Add In, a new node will be add-
ed as the last child node.

To add a new dynamic node before the selected node:

• Select Add from the Edit menu. As with Add In, the new table will 
be unnamed.
– The shortcut is <Ctrl+A>.

Adding Groups

It is possible to add a new test case group, a new test step group or a new 
default group in the Dynamic Part.

To add a new group before the selected node:

• Select Add Group from the Edit menu. 

To add a table to a group, select the group and Add In.

To add a new dynamic node as the last child of the selected node:

• Select Add In from the Edit menu.
– The shortcut is <Ctrl+Shift+A>.

To add a new group as the last child to the selected node:

• Select Add Group In from the Edit menu.
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Adding Compact Tables

It is possible to specify that all the test cases in a given group are dis-
played in the compact format (see Annex C, clause C.3 of 
ISO/IEC 9646-3). The following commands allow the insertion of com-
pact groups in the test suite hierarchy:

To add a compact group before the selected node:

• Select Add Compact Group from the Edit menu.

To add a compact group as the last child of the selected node:

• Select Add Compact Group In from the Edit menu.

Cutting, Copying and Pasting Nodes

You may cut or copy dynamic nodes. Dynamic nodes may also be past-
ed according to compatible classes, for example:

• Test suite parameters, test suite constants, test suite variables and 
test case variables may be pasted into each other.

• TTCN ASP, PDU, structured type and CM definitions may be past-
ed into each other and into TTCN ASP, PDU, structured type and 
CM constraints (and vice versa).

• ASN.1 ASP, PDU, structured type and CM definitions may be past-
ed into each other and into ASN.1 ASP, PDU, structured type and 
CM constraints (and vice versa).

• Test case, test step and default behaviors may be pasted into each 
other.

However, it is not possible to paste a constraint, for example, as a test 
case behaviour.

Paste is not available if the clipboard contains an object of an incompat-
ible type to the selected object.

To cut the selected node and its sub tree:

• Select Edit > Cut.
– The shortcut is <Ctrl+X>.
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Creating Constraints

The most convenient way of creating a constraint is to copy the corre-
sponding type and paste it as a constraint. Do this by copying the chosen 
type (ASP, PDU, CM or structured type), and then pasting it among the 
corresponding constraints. This works for both tabular constraints and 
for ASN.1 constraints.

The pasted table will have all its local names filled in. All that remains 
is to give the constraint a name and fill in the values.

Deleting Nodes

Dynamic nodes may be removed from the test document.

Undoing/Redoing Operations

All editing commands can be undone, and undone actions can be re-
done.

To copy the selected node and its sub tree:

• Select Edit > Copy.
– The shortcut is <Ctrl+C>.

To paste a node before the selected node:

• Select Edit > Paste.

To paste a node as the last child to the selected node:

• Select Edit > Paste In.
– The shortcut is <Ctrl+V>.

To delete the selected node and its sub tree:

• Select Delete from the Edit menu.

• To revert the last edit step, select Undo from the Edit menu.
– The shortcut is <Ctrl+Z>.
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Opening a Table
To open a table, either:

• Double-click a table node in the Browser. 

• Select a table node and then press <Enter> 

• Select a table node and then Open Table Editor from the View menu. 

It is possible to open several tables at the same time, but if it is more than 
ten, you will be asked to confirm it.

Printing a TTCN Document

For more information, see “The Print Dialogs in the TTCN Suite” on 
page 324 in chapter 5, Printing Documents and Diagrams.

• To revert the last Undo, select Redo from the Edit menu.
– The shortcut is <Ctrl+Y>.

To print a TTCN document:

• Select Print from the File menu.
– The shortcut is <Ctrl+P>.
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Editing Tables
The Table Editor is used for editing various TTCN tables. It displays the 
tables in three different parts: the header, the body and the footer. Each 
part, as well as many fields, can be resized.

You can edit tables by using the mouse and/or the keyboard. Rows in a 
table can easily be added, copied (both within a table and between other 
tables) and removed. The Table Editor shows the analysis status of the 
table contents, by use of colored text, and provides for immediate visual 
feedback during test simulation.

Resizing Cells and Table Parts
The three parts of a table – header, body and footer – are separated by 
horizontal bars, which you can drag to change the relative size and to 
hide parts of the table from view.

You can change the individual height of rows by dragging the leftmost 
row separator. In the body part, you may also change the individual 
width of columns by dragging the separators of the header fields.

Note that changing the column width may have effect on the row height, 
as the row will change to display all information it contains.

Figure 221: A Table Editor for a test case

Header part

Footer part

Body part
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Renaming a Table
To change the name of a table, you can either rename its node in the 
Browser or edit the table name in the table itself.

Setting the Input Focus
To set the input focus in another part of a table, either:

• Click in a cell in that part.

• Use <left arrow> and <right arrow> to move between the 
last field of one part and the first field of another part.

To set the input focus within a part, either point and click or use the ar-
row keys. There are also some shortcuts:

Editing Text in a Table
When you have used the keyboard to move the input focus to a field, the 
contents of the field will be replaced with the new text when you start 
typing. To edit the existing text, you have to press <Home> or <End> 
first.

If you use the mouse to explicitly set the input focus in a field, you can 
start editing the existing text directly with the keyboard.

The table fields will expand automatically to accommodate the text. 
You can also add a line break in the text by using <Return>.

To cut, copy and paste text in the fields, you use the corresponding com-
mands in the popup menu, the Edit menu or the standard Windows 

To Move to: Use This Key Combination

Next field in same row <Tab>

Previous field in same row <Shift+Tab>

Last field in same column <Ctrl+Down arrow>

First field in same column <Ctrl+Up arrow>

First field <Ctrl+Home>

Last field <Ctrl+End>
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shortcuts. However, note that it is only possible to paste text into a table 
field when the field contains a text pointer.

Auto completion of identifiers

When editing tables, it is possible to auto-complete identifier table 
names while editing text in the Table Editor. 

Start to type any identifier (a table with this name should already exist 
in the test suite). Type one or more letters, then press <CTRL-space>. 
TTCN Suite will find the tables that match the text typed. If one match 
is found, the typed name will be completed with the found one. If sev-
eral matches are found, a pop-up window with a list of names will be 
displayed. It is possible to select one by using keyboard (“Up”, “Down” 
arrows for navigate, “Enter” to select, “ESC” for cancel) or mouse (dou-
ble-click to select, click outside the window for cancel).

Editing Rows in the Body of a Table
You can add, delete, cut and copy rows in the body of all TTCN tables 
that contain more than one column. This is not possible in the headers 
and footers, since the formats of these parts of a table are defined by the 
TTCN standard.

The ASN.1 tables only have a single column with a single row and 
therefore adding, deleting, cutting and copying rows is not applicable. 
However, the contents of ASN.1 tables can still be copied, pasted, etc, 
as text.

Selecting and Deselecting Rows

• Select rows in the body of a table by clicking in the leftmost cell of 
a row (the “row button”). This deselects other selected rows.

• Select range of rows in the body by first selecting one row and then 
<Shift>-clicking another.

• Toggle the selection of a row by <Ctrl>-clicking the leftmost cell 
of the row.

Note:

The paste buffer for text is not the same as the one used for entire 
rows in the body of a table.
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Cutting, Copying and Pasting Rows

Rows in the body of a table may be cut, copied and pasted. Copy and 
Paste work across all the different tables although the Paste command 
is mainly intended for use among tables of the same or similar types.

To paste a row or rows before the current row:

• Select Paste In from the Edit menu.

It is possible to paste a row when a body row or field is selected.

Deleting rows

To delete the selected row or rows, select Delete from the Edit menu.

Note:

Setting the input focus will also deselect all selected rows.

To cut selected row or rows from the table: 

• Select Edit > Cut.
– The shortcut is <Ctrl+X>.

To copy selected row or rows:

• Select Edit > Copy.
– The shortcut is <Ctrl+C>.

To paste a row or rows:

• Select Edit > Paste.
– The shortcut is <Ctrl+V>.

Note:

The paste buffer for entire rows in the body of a table, is not the 
same as the one used for text.
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Inserting Rows

To insert a new tree header row before a selected row:

• Select Insert Local Tree Before from the Edit menu. 

Only one row may be selected. This command only works in dy-
namic behaviour tables. If no row is selected, the new row will be 
created first in the table.

To insert a new tree header row after a selected row:

• Select Insert Local Tree After from the Edit menu. 

Only one row may be selected. This command only works in dy-
namic behaviour tables. If no row is selected, the new row will be 
created last in the table.

You may also use <Ins> to insert rows. Where the row will be inserted 
depends on the input focus:

• If input focus is in the header or footer of a table, a new row is added 
after the last row in the body of the table. 

• If input focus is set on a field in the body of the table, a new row is 
added after the field that has the input focus. The input focus will be 
transferred to the corresponding field in the new row. 

To insert a new row before a selected row:

• Select Insert New Row Before from the Edit menu. 

Only one row may be selected. If no row is selected, the new row 
will be created first in the table.

– The shortcut is <Ctrl+Ins>.

To insert a new row after a selected row:

• Select Insert New Row After from the Edit menu. 

Only one row may be selected. If no row is selected, the new row 
will be created last in the table.

– The shortcut is <Ins>.
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• <Ctrl+Ins> gives the same effect as above but the new row is in-
serted before the row/field.

Indenting Behaviour Lines

The indention of behaviour lines can be increased and decreased:

Browsing in the Table Editor
If you right-click a table field containing an identifier, you may open the 
table representing the identifier from the pop-up menu:

• To save the current table in the history and display the definition of 
the selected identifier in the current Table Editor:

– Select Open <Identifier> from the pop-up menu.

• To display a pop-up menu containing the header rows of the identi-
fied table:

– <Control>-right-click the identifier.

• If the identifier is associated with a one-line table, the whole table 
is displayed in the pop-up. To select the identifier in the popup will 
have the same effect as Open <Identifier> (described above).

• To open the table associated with the identifier in a new Table Edi-
tor window:

– Select Open <Identifier> in New Window from the popup 
menu. 

The new window gets a new (empty) history buffer and is complete-
ly independent of the table from which it was opened.

To increase the indentation of a row in focus, or selected rows, by one 
position:

• Select Increase Indention Level from the Edit menu. 

To decrease the indentation of row in focus, or the selected rows, by one 
position:

• Select Decrease Indention Level from the Edit menu. 
July 2003 Telelogic Tau 4.5 User’s Manual ,um-st1 1251



Chapter 31 Editing TTCN Documents (in Windows) 
The Table Editor maintains a history of tables displayed with Open 
<Identifier> described above. This is similar to going back and forward 
in a web browser:

To go forward in the history of the Table Editor:

• Select Go Forward from the popup menu or the View menu.

To go back in the history of the Table Editor:

• Select Go Back from the popup menu or the View menu.
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Creating Behaviour Lines
The Data Dictionary gives you an alternative way of writing behaviour 
lines, by providing easy access to lists of PCOs, types, constraints, tim-
ers, etc, that you have already defined

Before you can use the Data Dictionary, the TTCN document has to be 
analyzed, because PCOs, types and constraints with major reference 
problems or missing type references will not be presented in the lists in 
the dialog.

Opening the Data Dictionary
To open the Data Dictionary:

1. Select a body row in a behaviour table.

– If you have not inserted a behaviour line yet, the input focus 
should be somewhere in the header of the table.

2. Select Data Dictionary from the View menu. 

It is only possible to have one Data Dictionary dialog opened.

The Data Dictionary dialog contains: 

• Three different tabs: Send/Receive, Timer and Attachment, from 
which you can select different statements to generate.

• Three fields: Behaviour Line, Constraint and Verdict, whose con-
tents will be inserted as a TTCN line in the table. It is also possible 
to edit the fields manually.

• Three buttons: Apply, Clear and Close (the first two only enabled 
when a body row of a behaviour table is selected):

– Click the Apply button to add a new row – containing the con-
tents of the Behaviour Line, Constraint and Verdict fields – to 
the table. 

– Click the Clear button to reset the dialog and deselect all selec-
tions in the current tab.
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Generating a Send or Receive Statement
Generate a send or receive statement by selecting a PCO, a type and a 
constraint. You can also add a timer, assignment and qualifier. 

To add a send or receive statement:

1. Select the Send/Receive tab.

2. Select a PCO.

The Type and Constraints list will be updated and only show the en-
tries that are valid for the currently selected PCO.

3. Select the ! radio button for a send statement or the ? radio button 
for a receive statement.

4. Select an ASP or a PDU in the Types list.

The PCO and Constraints lists will be updated accordingly.

5. Select a constraint.

The Type and Constraints list will be updated.

– If the constraint is a parametric constraint, a choice for each pa-
rameter will be displayed in the Constraints Parameter area, 
which you can select.

Figure 222: The Send/Receive tab in the Data Dictionary dialog
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6. Optionally you can add a timer statement by selecting the Start or 
Cancel radio button.

To insert a start statement, you also have to select a timer.

It is not possible to select timeout or to specify a timeout value here. 
You have to do that in the Timer tab of the dialog.

7. Optionally, add assignments separated by commas and without pa-
renthesis.

8. Optionally, add qualifier statements, without brackets.

9. Optionally, add a verdict.

10. Click Apply

A new row – containing the contents of the Behaviour Line, Con-
straint and Verdict fields in the dialog – will be added after the cur-
rently selected row and the new row will be selected.

Adding a Timer Statement
In the Timer tab, you may generate a StartTimer, CancelTimer or a Tim-
eout statement. As described above, you can also add timer statements 
from the Send/Receive tab. The difference is that from this tab you can 
also add Timeout value to the timer and you can add a timeout state-
ment.

Figure 223: The Timer tab in the Data Dictionary dialog
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To add a timer statement:

1. Select the Timer tab in the dialog.

2. Select a timer.

3. Select the Start, Cancel or Timeout radio button.

4. If you selected Start or Timeout, you also have to specify a timer du-
ration in the Timeout field.

5. Click Apply.

A new row – containing the contents of the Behaviour Line, Con-
straint and Verdict fields in the dialog – will be added after the cur-
rently selected row and the new row will be selected.

Adding an Attachment Statement
Generate an Attachment statement by selecting a test step and specify-
ing an actual parameter list (if the test step has a formal parameter list).

To add an attachment statement:

1. Select the Attachment tab.

2. Select an attachment.

3. If the selected test step has a formal parameter list, specify the pa-
rameter values in the Attachment Parameters area.

Figure 224: The Attachment tab in the Data Dictionary dialog
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Viewing Log Information
The Log Manager is a collection of log outputs, where each test system 
component can report information. The Log Manager contains one log 
per test component, and one common pane that is used for general in-
formation.

Examples of actions that can result in log information:

• Analysis of one or more tables: The resulting errors (if any).

• Opening an MP file: Result of the operation.

• Simulation: Simulator traces are reported on both the component 
log, and the general log.

The Log Manager can be configured to behave in various ways. The de-
fault setting is for the Log Manager to be hidden, but appear whenever 
log output is present. Only one instance of the Log Manager is avail-
able.

The contents of each log can be saved as a text file.

You can open tables by clicking and then <Ctrl>-right-clicking the 
name of the table in the log.

Figure 225: The Log Manager window
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Automatic Appearance
The Log Manager can be made to automatically become visible when-
ever new information is available in a log. This can be handy to reduce 
the amount of windows open at a given time as the Log Manager can be 
closed when it is not needed.

To allow the Log Manager to automatically open whenever new infor-
mation is available:

• Select Auto-Raise Log from the Log menu.

Changing the Appearance of the Log
The log font can be made smaller or larger, allowing more information 
to be viewed or increased readability.

To make the log text larger:

• Select Increase Log Font Size in the Log menu.
– The shortcut is <Ctrl+Alt+L>

To make the log text smaller:

• Select Decrease Log Font Size in the Log menu.
– The shortcut is <Ctrl+Shift+L>

Exporting Information from the Log
The information contained in a log can be copied to the clipboard, or 
saved to disk as an ordinary text file. In addition to normal text-selec-
tion, all text can also be selected with one operation.

To select all text:

• Select Select All In Log in the Log menu.

To copy the selection to the clipboard:

• Select Copy Log in the Log menu.

To save all text in a log to a file:

• Select Save Log in the Log menu.
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Clearing the Log
To clear the displayed log:

• Select Clear Log in the Log menu
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Finding and Sorting Tables
As an alternative to the Browser, you can use the Finder for displaying 
TTCN tables in a list, without the ordering restrictions imposed by the 
TTCN tree structure.

You can search for and display tables in the Finder. The search may for 
example be based on name, type and content. You can either use the en-
tire TTCN document (the Browser contents) or the Finder list as search 
source, and extend or restrict the number of tables displayed in any 
number of steps.

Another way of searching is relationally. This means that you search for 
tables that reference or are referenced by tables selected in the Finder. 
The relational search cannot be combined with the ordinary.

The tables that will be displayed after a search, can be sorted by a num-
ber of criteria:

• Name
• Type
• Path in the test tree
• Parse status
• Latest analyze time stamp
• Latest modification time

Reversed sorting is also possible.

In addition, it is possible to for example open, analyze, rename and de-
lete tables from the Finder, but not cut, copy, paste and insert since that 
require a tree context.
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Opening the Finder

The Finder consists of three areas:

• The Find/Relational Find area, where you specify criteria for the ta-
bles to be found and inserted in the Results List.

• The Search In area, where you can select to search for tables in the 
entire document or only in the Results List.

• The Results List, where the sorted list of TTCN tables are kept.

About Search Criteria
Search criteria are used for restricting a search. This means that if you 
do not specify any search criteria – all fields are empty and no buttons 
are clicked – before you click the Find button, all dynamic TTCN tables 
of the test system component will be displayed. 

Consequently, if you specify one or more search criteria, TTCN tables 
that match at least one of the criteria, will be displayed in the Finder. 
Additionally, this means that specifying all possible search criteria has 

To open the Finder:

• Select Open Finder from the View menu.
– The shortcut is <Ctrl+F>

Figure 226: The Finder
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the same effect as specifying none. This is merely as a convenience for 
quickly adding all tables of the test system component, as the closed 
search criteria is not meaningful.

Finding Tables

To search for tables:

1. Select the Find tab.

2. Select Document in the Search in area to search for tables in the en-
tire TTCN document.

– If you select Results List, the search criteria will be used to re-
strict the set of TTCN tables already present in the Results List.

3. Select one or several table types in the Of type list.

This list contains all existing TTCN and ASN.1 table types support-
ed.

Note:

The search criteria are used for an OR-style search.

Figure 227: The Find tab in the Finder
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4. Click a Search mode radio button.

This selection affects the text you type in the Name and Contains 
fields. If you are not going to use those fields in the search, the 
search mode does not affect the search at all.

– Wildcard

The Name and Contains fields can contain wildcards. This 
means that “a*body” will match “anybody” and “antibody”, 
while “a??body” only will match “anybody”.

– Regular expression

The Name and Contains fields contain regular expression, with 
its more advanced syntax and matching possibilities. This 
means that “any[bt]” will match “anybody” and “anything” but 
not “anyone”.

– Literal 

The Name and Contains fields contain the exact text. This 
means that “any?” only will match “any?”.

5. Optionally, type some text in the Name field.

The tables with names that match will be found.

6. Optionally, type some text in the Contains field.

The tables with contents that match will be found.

7. Optionally, click one or several Status buttons to sort out tables of a 
different parse status.

For example, if you select the error button, only tables with errone-
ous parse status will be found.

8. Click Find.

Tables that match at least one of the search criteria you have speci-
fied will be displayed in the Results List.
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Finding Tables Relationally

You can search for tables that are referenced by and that reference ta-
bles that are displayed and selected in the Results list. To do this: 

1. Select the Relational Find tab.

2. Select one or several tables in the Results List.

3. Select one of the following radio buttons:

– All nodes directly referenced by the selected node(s)

Replaces the contents of the Results List with all nodes that are 
directly referenced by the tables currently selected in the list.

– All nodes directly and indirectly referenced by the selected 
node(s)

Same as above, but expands the search to include tables that are 
referenced by the referenced tables, and so forth.

– All nodes that reference the selected node(s)

Replaces the contents of the Results List with all nodes that ref-
erence the tables selected in the list.

4. Click Find.

The Results List will be updated in accordance with your settings.

Figure 228: The Relational Find tab in the Finder
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Editing and Sorting the Results List
The Results List contains a subset of all dynamic TTCN tables in the 
TTCN document. You can perform most standard operation on the ta-
bles. However, it is not possible to cut, copy, paste or insert tables, since 
this requires the structural context of the Browser.

Sorting the Results List

The contents of the Results List can be sorted if you click on the header 
of the information column. The available information is:

• Name

The name of the table.

• Type 

The TTCN or ASN.1 type of the table.

• Path 

The path of the tree leading to this table on the form root/..../par-
ent/node.

• Analyze status 

The parse status of the table.

• Analyze time 

The last time the table was analyzed.

• Modify time 

The last time the table was modified.

Click a second time on the header to sort the list in reverse order.

Clearing the Results List

Click Clear to clear the contents of the Results List.

Caution!

Even if the elements of the Results List are presented without struc-
tural ordering, they still follow the TTCN hierarchy. This means that 
if you delete a group node, the group and its entire sub tree will be 
removed.
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Converting to TTCN-MP
TTCN-GR – the graphical notation – is the format used when you edit 
or print a test suite in the TTCN suite. TTCN-MP – the textual notation 
(machine processable) – can be used when you want to import a TTCN 
document into a non-TTCN suite tool or make backups.

To convert a TTCN document to TTCN-MP, either:

• Select Save As from the File menu.

This opens a dialog where you can save the current document as 
TTCN-MP.

• Click the Export to MP button. 

This opens a dialog where you can export the current document to 
TTCN-MP. The MP file will be written to disk, but not opened.

Both TTCN-MP and TTCN-GR can be opened in TTCN Suite.

For a full supported EBNF, see “The TTCN-MP Syntax Productions in 
BNF” on page 1530 in chapter 39, Languages Supported in the TTCN 
Suite.

The Standard MP Format
When you convert to MP, the TTCN document does not have to be an-
alyzed or correct. TTCN-MP will be generated even for documents that 
are neither complete nor error-free. This implies that the generated MP 
file may be, but is not necessarily, conformant to the standardized 
TTCN-MP format

However, to ensure that the TTCN-MP document can be read by a non-
TTCN suite tool, you should analyze the document and correct any er-
rors.

The Telelogic MP Format
An optional but non-standard TTCN-MP for compact tables and ASN.1 
references is supported. Additional fields in dynamic tables (fields 
which are transferred to test suite overview tables) are also supported. 
You are recommended to use this format for transferring TTCN docu-
ment between the TTCN suite instances and for making backups of the 
TTCN documents. Otherwise it works just as the standard MP format.
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MP File Format Problem when Opening
When you open certain TTCN-MP documents, a problem with transfer-
ring the information (e.g. description) in the overview tables to the ta-
bles in Dynamic Part, may occur.

The TTCN standard allow path specifications to optionally include the 
document name first. This has the unfortunate effect that if the TTCN 
document contains a top level group with the same name as the TTCN 
document, there is, in general, no way of knowing if the first part of the 
paths is a group identifier or the TTCN document identifier.

TTCN Suite assumes that if the first part of the path is equal to the doc-
ument name, it is the optional document name and, when converting, 
strips it away. When the document is saved as or exported to MP, the 
document name is always added to the front of all paths. That way, 
TTCN Suite is always able to open the MP files it exports.

If the TTCN document contains top level group identifiers equal to the 
document name, and TTCN Suite is unable to resolve the paths, tempo-
rarily change the document name in the MP file and change it back once 
inside TTCN Suite.

Note that ITEX 2.0 did not add the document name at export, and there-
fore the problem described may apply when open MP files exported by 
ITEX 2.0.

Fields Containing the ‘$’ Character
The contents of table fields in a TTCN-MP file are usually ignored. 
However, to make it possible to open non-bounded free text fields (for 
example TS_VarValue field) with embedded dollar characters (‘$’), 
those fields will be syntax checked. This means that it is not possible to 
convert TTCN documents containing unmatched single or double 
quotes in non-bounded freetext fields, that is, when you open a TTCN-
MP file, syntax errors in those fields will not be tolerated.

Revision Control
There is no integrated revision control system in the TTCN suite. Since 
normal visible files are used to store the TTCN documents, it is easy to 
integrate the TTCN suite in a revision control system. However, since 
the.itex file format is binary, it is better to use the TTCN-MP format.
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Converting to HTML
It is possible to export a TTCN document, or only a part of it, to HTML. 
The result will be one HTML-file containing what you selected to ex-
port, and – when applicable – hypertext links as well as information 
about the structure of the test suite will also be generated. 

To convert a TTCN document to HTML:

1. Select the top node in the Browser.

– You may also select only a part of the test suite, but multiple-
selection is not possible.

2. Select Save As from the File menu.

A dialog will be opened where you can save the document as 
HTML.

It is also possible to convert a currently opened table to HTML. To do 
this:

• Select Generate HTML from the pop-up menu in the Table Editor.
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Shortcuts

Common Shortcuts

Browser Shortcuts

Shortcut Action

Ctrl+N Creates a new test suite.

Ctrl+O Opens an existing test suite.

Ctrl+S Saves the test suite to file.

Ctrl+P Prints the test suite.

Ctrl+Z Undoes latest editing action(s).

Ctrl+Y Redoes latest undone editing action(s).

Ctrl+L Shows/Hides Log Manager.

Ctrl+F Opens a new Finder.

F7 Analyzes the selected node and its sub-tree.

F8 Generates code for the current test suite.

Alt+F8 Displays an options dialog to allow the user to set op-
tions for tools working on the Browser.

F5 Runs/continues current simulation.

Pause Pauses current simulation.

Ctrl+Break Aborts current simulation.

F11 Steps current simulation.

Shortcut Action

<Up arrow> Sets the focus to the above node in the Browser.

<Down arrow> Sets the focus to the below node in the Browser.

<Right arrow> If the selected node is collapsed and has children, it will 
be expanded. If the selected node is expanded and has 
children the selection will move to the first child.
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<Left arrow> If the selected node is the root of an expanded sub-tree, 
the sub-tree will be collapsed. If the selected node is the 
root of a collapsed sub-tree the selection will move to 
the parent of the current node (if any).

<Ctrl+X> Cuts the selected non-static node in the Browser.

<Ctrl+C> Copies the selected non-static node in the Browser.

<Ctrl+V> Pastes the contents of the cut/copy buffer after the se-
lected node.

<Ctrl+Shift+V> Pastes the contents of the cut/copy buffer as a child to 
the selected node.

<Delete> Deletes selected node(s).

<Enter> Opens a Table Editor for each selected node.

<Ctrl+A> Adds a new table after the selected node.

<Ctrl+Shift+A> Adds a new table as a child to the selected node.

Click Sets selection on a node in the Browser.

Right-click If the mouse pointer is above a node, sets selection on 
that node and display node specific pop-up menu. If no 
node is selected, displays background pop-up menu.

Double-click If the selected node is a static node, the sub-tree will ei-
ther be collapsed or expanded. If the selected node is a 
collapsed group, its sub-tree will be expanded. Other-
wise the associated group table is opened. Finally, if 
the node is a non-static table a Table Editor for that 
node will be opened.

<Shift>-click Selects/deselects all nodes between this selected node 
and the previously selected nodes.

<Ctrl>-click Selects/deselects a node without affecting already se-
lected nodes.

Shortcut Action
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Table Editor Shortcuts

Log Manager Shortcuts

Shortcut Action

<Tab> Moves to the next editable field.

<Shift+Tab> Moves to the previous editable field.

<Ctrl+Up arrow> Moves to the previous line.

<Ctrl+Left arrow> Moves to the next editable field.

<Ctrl+Down arrow> Moves to the next line.

<Ctrl+Right arrow> Moves to the previous editable field.

<Ctrl+Space> Toggles selection of current row in a table body.

<Alt+Left arrow> Moves forward in history.

<Alt+Right arrow> Move back in history.

<Page Up>/<Page Down> Scroll stable one page.

<F7> Analyzes the current table.

<Ctrl+X> Cuts selected rows.

<Ctrl+V> Pastes rows after the selected row, or last if no selection 
exist.

<Ctrl+C> Copies selected rows.

<F9> Toggles breakpoint on selected row(s)

Right-click Context sensitive popup.

<Ctrl>-right-click Displays the definition of the currently selected identi-
fier.

Click Sets text selection and clear row selection.

<Ctrl>-click Toggles row selection.

Shortcut Action

<Ctrl+Alt+L> Increases font size.

<Ctrl+Shift+L> Decreases font size.
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Finder Shortcuts

Shortcut Action

<Up arrow> Sets the focus to the above node in the Results List.

<Down arrow> Sets the focus to the below node in the Results List.

<Ctrl+C> Copies the selected non-static node in the Results List.

<Delete> Deletes selected node(s).

<Enter> Opens a Table Editor for each selected node.

Click Sets selection on a node in the Results List.

Right-click If the mouse pointer is above a node, sets selection on 
that node and display node specific pop-up menu. If no 
node is selected, displays background pop-up menu.

Double-click Opens a Table Editor for the selected node.

<Shift>-click Selects/deselects all nodes between this selected node 
and the previously selected nodes.

<Ctrl>-click Selects/deselects a node without affecting already se-
lected nodes.
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