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Chapter
1 User Interface and Basic 

Operations
This chapter describes the general graphical concepts that are used 
throughout the user interfaces of the Telelogic Tau tools. It also de-
scribes some common menu choices. This information will not be 
repeated in other chapters of the User’s Manual.

You should have a basic understanding of the Telelogic Tau tools 
concepts and tool family before you read this chapter. Such infor-
mation can be found in:

• chapter 2, Introduction to the SDL Suite, in the SDL Suite Getting 
Started

• chapter 3, Introduction to the TTCN Suite (on UNIX), in the 
TTCN Suite Getting Started

• chapter 2, Introduction to the TTCN Suite (in Windows), in the 
TTCN Suite Getting Started
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Chapter 1 User Interface and Basic Operations 
Graphical Environments and Style Guides
The Telelogic Tau tools family is designed to be available on worksta-
tions running UNIX and on PCs running Windows. Since the majority 
of the Telelogic Tau tools are graphical, it is assumed that the computer 
you are to run the Telelogic Tau tools on has the required graphical sup-
port.

Telelogic supports the following graphical environments:

• On UNIX workstations, the X Windows system, managed by the 
Motif window manager. The versions currently supported are X11 
R5 and Motif 1.2.

• On PCs, the Microsoft Windows system. Telelogic Tau supports 
Windows 95, Windows 98, Windows NT 4.0 and Windows 2000.

Throughout the Telelogic Tau manuals, it is assumed that you are famil-
iar with the graphical environment that is currently used. Otherwise, we 
recommend you to read the literature that describes that graphical envi-
ronment. See for instance “References” on page 38.

The SDL suite for Windows is fully compatible with the SDL suite on 
UNIX workstations, with respect to functionality and storage formats. 
However, since they are implemented on different graphical environ-
ments, there may be slight differences in the appearance of each tool. 
Also, we have tried to adopt the respective style guide for each environ-
ment as long as feasible, but have been forced to compromise in order 
to provide a uniform user interface between the UNIX workstation and 
PC environments.

Constraints
The constraints that are imposed on the Telelogic Tau tools by the 
graphical environment are identified in “Microsoft Windows System 
Factors” on page 48, “X Window System Factors (UNIX only)” on 
page 49 and “OSF/Motif Factors (UNIX only)” on page 51 in chapter 4, 
System Setup, in the Installation Guide.
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 Application Windows
Application Windows
All the Telelogic Tau tools have a main window with a common general 
appearance. The tools may also have sub windows that depend on the 
main window. Apart from these, there are also dialog windows, see “Di-
alog Windows” on page 28.

In the TTCN suite in Windows, the windows will be displayed in the 
working area of the TTCN suite desktop.

Main Windows
A general main window of a Telelogic Tau tool in Windows and on 
UNIX, as well as the TTCN suite desktop in Windows, is depicted and 
explained below:

Figure 1: A Telelogic Tau main window (in Windows)
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Chapter 1 User Interface and Basic Operations 
Figure 2: A Telelogic Tau tool main window (on UNIX)

Figure 3: The TTCN suite desktop (in Windows)
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Title Bar

The title bar may identify the tool family, the tool and the opened doc-
ument. In some tools, an asterisk signifies that the document is not 
saved since the last change.

Menu Bar

The menu bar contains pull-down menus. The menu choices operate ei-
ther on the whole document or file that is opened in the tool, or on any 
selected object(s). More information on menus and menu choices can be 
found in “General Menus” on page 8 and “General Menu Choices” on 
page 8.

You can “preview” the functionality of a menu choice by pointing to it. 
In the SDL suite on UNIX you also have to press the mouse button. An 
explanation will appear in the status bar.

If a menu or menu choice is dimmed, it is not appropriate or meaningful 
in the current situation, or the associated tool license is temporarily lost.

If a menu or menu choice is hidden, you do not have a license for the 
associated tool, or the tool has a long/short menu concept which allows 
hiding of menu choices.

Tool Bar

Most operations that the quick-buttons in the tool bar provide, have an 
exactly corresponding menu choice, but some quick-buttons have a 
slightly different functionality compared to their corresponding menu 
choice. See also “General Quick-Buttons” on page 24.

You can “preview” the functionality of a quick button by pointing to it. 
In the TTCN suite on UNIX you also have to press the mouse button. An 
explanation will appear in the status bar, and as a tool tip just below the 
button (not available in the TTCN suite on UNIX). 

In the TTCN suite in Windows, the tool bars are dockable on all sides 
of the desktop.

Drawing Area

The information a tool handles is displayed and may possibly be edited 
in the drawing area. The drawing area may also give access to popup 
menus. See also “The Drawing Area” on page 25.
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Working Area (only in the TTCN suite in Windows)

The working area of the desktop will display the TTCN suite windows 
that you open. For example, when you open a TTCN document, the 
Browser window will be displayed in the working area.

Tool Frame (only in the SDL suite on UNIX)

A tool frame, with a unique color for each tool, surrounds the drawing 
areas in the SDL suite. This makes it easier for you to identify a tool, 
without the need to see the whole drawing area or the title bar.

Status Bar

The status bar displays information about menu choices and quick-but-
tons, the progress or result of an invoked operation, and the name of a 
selected object or additional information about an object.

Sub Windows
A sub window of a Telelogic Tau tool is a window that depends on the 
main window of the tool. A sub window is opened either automatically 
when the main window is opened or as a result of user interaction with 
the main window. All sub windows are automatically closed when the 
main window exits. However, to close a sub window does not affect the 
main window.

The TTCN Suite Logs
Some TTCN suite tools, for example the Analyzer, produce logs. 

On UNIX, the relevant tool dialog allows the log device to be set to 
Screen, File or None. If set to Screen, the log will be displayed in its 
own log window. If set to File, a directory dialog will be displayed 
where you can specify a file to save the log in.

In Windows, the Log Manager will display the logs, and tabs are used 
for viewing different logs. The contents of the window can be copied 
and saved. For more information, see “Viewing Log Information” on 
page 1257 in chapter 31, Editing TTCN Documents (in Windows).
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Zooming a Window
You can change the scale of the drawing area of an SDL suite window 
by selecting Set Scale in the View menu or by using quick buttons for 
zooming in and out. The scale is normally between 20% and 800%.
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General Menus
The following menus are generally available in a menu bar:

• The File menu contains menu choices related to files, documents 
and the whole drawing area, as well as the tool/window itself. Ex-
amples: New, Open, Save, Print and Exit.

• The Edit menu contains menu choices concerning editing of the cur-
rent document. It may also contain menu choices for changing ob-
jects. Examples: Undo, Cut, Copy, Paste, Add and Edit.

• The View menu contains menu choices that changes the appearance 
of the window and the information in the drawing area. Examples: 
Expand, Collapse, Window Options and Set Scale.

• The Tools menu contains menu choices for starting tools and utili-
ties, and opening or raising other windows. Examples: Search, 
Show Organizer and Show <window name>.

• The Help menu contains menu choices for supporting you with help 
and other useful information.

General Menu Choices
Some common menu choices in Telelogic Tau are described below and 
the descriptions will not be repeated elsewhere.

File Menu
The most common menu choices in the File menu of the Telelogic Tau 
tools are only described in this section. If a tool provides additional 
menu choices in the File menu, they will be described in the corre-
sponding chapter. If a common menu choice has a different functional-
ity, it will also be described in its corresponding chapter but minor dif-
ferences will be mentioned below.
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New

When you select this menu choice, a new document, diagram or file will 
be created and displayed. In some tools, it will be given a default file 
name which you later may change, and in some tools you have to spec-
ify the name and the type of document/diagram in a dialog before it will 
be displayed.

• For information on adding new pages to SDL diagrams, see “Add” 
on page 1969 in chapter 44, Using the SDL Editor.

• In the Text Editor, you have to select in a dialog whether to create a 
new file, copy an existing file, or to copy a template file. The direc-
tory for template files is defined by the preference TE*TextTem-
plateDirectory. For more information, see “Text Editor Preferenc-
es” on page 258 in chapter 3, The Preference Manager.

• When you create a new link file in the Link Manager, the current 
endpoint and link information will be deleted. You will be warned 
if a link file is already opened.

Open

When you select this menu choice, a file selection dialog will be issued, 
in which you select what file to open. For more information, see “File 
Selection Dialog” on page 30.

A default file filter, which depends on the tool, will be used. It corre-
sponds to the default file name extensions applied when a document or 
diagram is saved (see “Save” on page 11). The tools and the filters are 
listed in the table below.

• When you open a new SDL simulator, a currently running simulator 
will be stopped after user confirmation. The Watch window will be 
updated and the text area will be cleared from previously executed 
commands.

• When you open a new link file in the Link Manager, a currently 
opened and modified file has to be saved first.
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Tool Default File Filter

SDL Target Tester *.sym

SDL Coverage Viewer *.cov

HMSC Editor *.mrm

Index Viewer *.xrf

The TTCN suite in Windows *.itex

Link Manager *.sli

MSC Editor *.m??

OM Editor *.som

Organizer Log *.log

SDL Editor *.s??

SDL Simulator *_sm*.exe (in Windows)
*.sct (on UNIX)

SDL Validator *_vl*.exe (in Windows)
*.val (on UNIX)

State Chart Editor *.ssc

Text Editor *.txt

Note:

No specific file name extension on diagrams are imposed. If other 
file name extensions than the ones suggested have been used when 
saving diagrams, a different filter than the given must be applied.

Note: The MSC Editor and instance oriented MSC/PR

The MSC Editor supports reading MSC/GR (default file name ex-
tension is .msc) and MSC/PR (default file name extension is 
.mpr). However, the MSC Editor cannot read MSC/PR expressed in 
instance-oriented form. Only the event-oriented form can be read by 
the tool. See the Z.120 recommendation for more information on 
these two alternative formats.
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Save

When you select this menu choice, the current information in the docu-
ment/diagram/window will be saved in a file. 

When you save a document/diagram for the first time, a file selection 
dialog is opened. A default file name and file name extension is suggest-
ed. You have to specify where the file is to be saved and you may also 
change the file name and extension. If you try to overwrite an existing 
file, you will be warned.

Note: Opening *.cif files in SDL editor

If a *.cif file is opened in an SDL editor, then the information from 
the SDL/CIF file is presented in a new, dirty and unsaved diagram 
buffer.

Note:

If you keep the file name extensions for different documents/dia-
grams listed below, it will be easier to locate the files. It is also im-
possible to add an existing file to the Organizer unless it has the de-
fault extension.

Document/Diagram Type or Storage Format
Default File or 
Extension

Command definitions (SDL Simulator UI) .cmds

Coverage .cov

HMSC .mrm

Link file .sli

MSC .msc

Object Model .som

Organizer Log .log

SDL System .ssy

SDL Block .sbk

SDL Substructure .ssu

SDL Service .ssv
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Save Document

The Save Document menu choice only exists in the TTCN Browser and 
Table Editor on UNIX. When you select it, the TTCN document will be 
saved. See also “Save” on page 11.

Save As

Select this menu choice to save the current document/diagram in a new 
file. A default file name and file name extension will be suggested, see 
“Save” on page 11. If you change the file name and extension and try to 
overwrite an existing file, you will be warned.

If the document/diagram was already connected in the Organizer, it will 
be reconnected to the newly created file. This does not happen in the fol-
lowing cases:

SDL Process .spr

SDL Procedure .spd

SDL System Type .sst

SDL Block Type .sbt

SDL Service Type .svt

SDL Process Type .spt

SDL Macro Definition .smc

SDL Operator .sop

SDL Package .sun

SDL Overview .sov

State Chart .ssc

State Overview .ins

Text .txt

TTCN test suite (in Windows) .itex
.mp
.imp

Variable definitions (SDL Simulator UI) .vars

Document/Diagram Type or Storage Format Default File or 
Extension
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• Save As Text. By specifying *.txt as the file name extension for 
graphical diagrams, the diagram text will be saved in the specified 
file.

• Save As CIF. By specifying *.cif as the file name extension for SDL 
diagrams, the diagram will be saved in SDL/CIF format, a standard-
ized textual format that includes layout information. When this ex-
tension is used in the SDL editor and the Save As dialog is closed, 
you will be asked to select diagram pages to include in the generated 
file. As default, all pages are selected. A *.cif file can be opened in 
the SDL editor. When doing so, the information from the *.cif file 
is presented as a new, dirty and unsaved diagram buffer.

• In the TTCN suite on UNIX, there are three alternatives for compres-
sion when you save as TTCN-GR: None, Gzip and Compress. None 
gives maximum compatibility. Gzip is preferred over Compress, 
both for portability and performance.

Save a Copy As

This menu choice is available in the SDL suite editors. It saves a copy 
of the current document/diagram in a new file.

The name of the new file is to be specified in a file selection dialog and 
a default file name and extension will be suggested; see “Save” on page 
11. If you try to overwrite an existing file, you will be warned.

Note:

If you keep the file name extensions for different documents/dia-
grams listed above, it will be easier to locate the files. It is also im-
possible to add an existing file to the Organizer unless it has the de-
fault extension. In the TTCN suite in Windows, you can only open 
test suites that have the extension .itex, .mp or .imp.

Note:

The window will hold the original file, not the newly saved copy. 
The document/diagram remains connected to the old file and the Or-
ganizer’s structure is left unaffected by the operation.
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Save All

This menu choice is available in the SDL suite editors. It saves all mod-
ified documents/diagrams that are opened. Except for that, it works as 
described in “Save” on page 11. 

Print

The different Print dialogs and how to print is described in chapter 5, 
Printing Documents and Diagrams.

Close

When you select this menu choice, the current document/diagram (or in 
some cases the window) will be closed. In most documents, you will not 
have to confirm the closing. 

• In the TTCN suite, when you close the last open Browser on a doc-
ument, you will be asked for confirmation if it has not been saved.

• When you close the Link Manager window, the Link Manager will 
still be active in the background but the user interface will not be 
available.

• In the TTCN-SDL Co-simulator Editor on UNIX, the window is 
closed, but current document is not closed until the associated setup 
is closed.

• In the SimUI’s Command window, the commands currently dis-
played will be saved and shown again when the window is opened 
again. This is also valid for the variables in the Watch window.

Close Diagram

This menu choice is available in the SDL suite editors. When you select 
it, the current diagram will be closed. If changes in the diagram have not 
been saved, a dialog will be issued where you can select to save or not 
before closing.

If the closed diagram was the last open diagram, the editor will exit. If 
there are more editor windows open, the window will be closed. If there 
is only one editor window, but more diagrams open, another diagram 
will be displayed in the window.
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Revert Diagram

This menu choice is available in the SDL suite editors. When you select 
it, the current diagram will be re-loaded from the file system. This op-
eration is useful if the file has changed in any way in the file system.

Exit

When you select this menu choice, the current tool will exit. If a docu-
ment/diagram has been changed since last save, a dialog will be issued 
where you may select to save it, not save it or – where applicable – save 
all opened documents/diagrams or quit without saving anything.

• In the SDL Simulator, you will be asked to save unsaved changes to 
the SimUI’s definition files. See “Definition Files” on page 2152 in 
chapter 50, The SDL Simulator.

Tools Menu
A Tools menu is available in most Telelogic Tau tools. It contains var-
ious menu choices, but the following is included in almost all Tools 
menus:

Show Organizer

This menu choice raises the parent Organizer main window, that is from 
where the tool was started.

Help Menu
A Help menu is available in most main and sub windows of the Telel-
ogic Tau tools. However, the menu choices in this menu are not the 
same in each tool or on each platform, but they work in the same way: 
When you select a menu choice in the Help menu, a help viewer will be 
opened with the corresponding help topic.

The following Help menu choices, that may need an explanation, are 
described below:

• About <Tool>
• Help Desk
• Index
• Latest News
• License Information
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• License Info
• New Features
• On Field
• On Shortcuts
• On Window
• Search
• Telelogic Home Page

About <Tool>

Opens the About message box for the tool that the menu choice was in-
voked from, which gives information on the current tool version, copy-
right, etc.

Help Desk

Opens the Web browser with a page on the World Wide Web from Tele-
logic’s Help Desk 
(http://www.telelogic.com/usersupp/usersupp.asp). This 
menu choice is only available in the Organizer.

Index

Opens the help viewer with an index of all entries in the Telelogic Tau 
documentation. This menu choice is only available in the Organizer.

Latest News

Opens the help viewer with a “readme” file, containing late information 
about the release.

License Information

Opens a dialog with license information for all tools in Telelogic Tau. 
For more information on this dialog, see “License Information” on page 
162 in chapter 2, The Organizer. This menu choice is available in the 
Organizer.

License Info

On UNIX, this menu choice opens a dialog with additional license infor-
mation on the TTCN suite tools. For more information, see “License In-
fo” on page 1115 in chapter 25, The TTCN Browser (on UNIX). In Win-
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 General Menu Choices
dows, the dialog lists the Telelogic Tau licenses currently in use as well 
as the number of licenses available for each tool. 

New Features

Opens the help viewer with information about new and changed func-
tionality.

On Field

This menu choice is available in the TTCN Table Editor on UNIX. It dis-
plays the TTCN BNF syntax applicable for the relevant field.

On Shortcuts

Opens the help viewer with information about various user interface 
shortcuts that can be used within the Organizer tool.

On Window

Opens a text describing the TTCN suite tool that the menu choice was 
invoked from. This menu choice is only available in the TTCN suite on 
UNIX.

Search

Starts a textual search across all help files. This menu choice is available 
in the Organizer and all the SDL suite tools.

Telelogic Home Page

Opens the web browser with Telelogic’s home page on the World Wide 
Web (http://www.telelogic.com). This menu choice is only avail-
able in the Organizer.
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Defining Menus in the SDL Suite
The graphical the SDL suite tools allow you to define additional menus 
and menu items that execute external commands or send PostMaster 
messages. Separate user-defined menus can be defined and added to 
each graphical tool. However, the pre-defined menus in each tool can 
not be removed or changed.

User-defined menus are described by menu definition files that are read 
by the tools when they start up.

It is sometimes more useful to add user-defined menus to the tools after 
they have been started; this can be accomplished if you use the Telelog-
ic Public Interface. For more information see “Menu Manipulation Ser-
vices” on page 525 in chapter 12, The Telelogic Tau Public Interface.

Tools and Menu Definition File Names
Menu definition files must have fixed names that indicate which tool the 
menus are intended for.

The following tools allow addition of user-defined menus, and also of-
fer the possibility of letting the menu commands access the internal 
state information of the tool. This is accomplished if you use format 
codes that are documented separately for each tool in the Public Inter-
face. 

Note:

The fact that a set of menus have been defined in a menu definition 
file, does not prevent using the public interface services to add ad-
ditional menus, or even to modify the menus that were defined by 
the menu definition file.

Tool Menu definition file name

Organizer org-menus.ini

MSC Editor msce-menus.ini

SDL Editor sdle-menus.ini

OM/SC/HMSC Editor ome-menus.ini

Text Editor te-menus.ini
18 ,um-st1 Telelogic Tau 4.5 User’s Manual July 2003
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The following tools allow addition of user-defined menus, but do not 
offer the possibility of accessing the internal state of the tool.

Menu Definition File Location
On start-up, each tool that supports menu-definition files will search for 
a menu definition file with the given pre-defined name in up to three lo-
cations:

1. First, the directory from where the SDL suite was started is 
searched. If a file with the expected name is found, the tool will at-
tempt to read it and install the menus described therein.

2. Second, the directory named in the HOME environment variable will 
be searched. If a file with the expected name is found, it will be 
used.

3. Last, the directory where the SDL suite is installed will be searched 
(on UNIX, $telelogic/, and in Windows the top installation direc-
tory, by default C:\Telelogic\SDL_TTCN_Suite4.5).

If no file is found, no user-defined menus will be added on start-up.

Tool Menu definition file name

Preference Manager pref-menus.ini

Type Viewer typ-menus.ini

Coverage Viewer cover-menus.ini

Index Viewer xref-menus.ini

Tree Viewer tree-menus.ini

Simulator/Validator UI a

a. In Windows, the Simulator/Validator UI’s can not read menu-definition files.

simui-menus.ini
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Format of Menu Definition Files
A menu definition file is a line-oriented text file separated into sections 
by lines containing special section markers. Each section contains lines 
formatted in the same way, containing an option/value pair. Each sec-
tion describes either a menu or a menu item.

The first line of a menu definition file is a format tag that identifies the 
file as menu definition file:

SDT-DYNAMICMENUS-3.6

Each section is started by adding a line with a section name between 
brackets “[ ]”. Valid sections in a menu definition file are:

[MENU]
[MENUITEM]
[MENUEND]

[MENU] Section

The menu section starts a new menu. Subsequent [MENUITEM] sections 
will add a menu item to this menu until a [MENUEND] section is encoun-
tered. A [MENU] section should be the first line after the initial tag or fol-
low directly after a [MENUEND] section.

After the [MENU] section tag follows the option below, using the syntax:

Name=NameOfMenu

Option Explanation/Value

Name A string that contains the name of the menu. The name is pre-
sented in the tool’s menu bar. The ampersand ‘&’ character 
may be placed just in front of a letter to indicate that this letter 
will be underlined in the menu name and thus function as a key-
board shortcut for menu traversal. Make sure that the letter is 
not used as a shortcut in any other menu in the menu bar, or it 
may not be possible to open the menu with the keyboard.
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[MENUITEM] Section

A [MENUITEM] section must occur between a [MENU] and a [MENUEND] 
section.

Following the [MENUITEM] section tag is a number of options and their 
values, using the syntax:

Option=Value

This section adds a menu choice to the specified menu. The menu 
choice could either perform an OS command or issue a PostMaster no-
tification when selected. The OS command to perform or the message 
to broadcast could be sensitive on a selected symbol. 

The exact interpretation of two of these options (ProprietaryKey and 
AttributeKey, described below) will depend on which tool the menu 
will be installed in. In particular, the ProprietaryKey option will only 
have significance in the Organizer and the graphical editors. The At-
tributeKey option will only have significance in the graphical editors. 
If not used these options should be set to 0.

For tools supporting access to internal state information, format codes 
can be used in the command string or as message parameter, providing 
additional context-sensitive information.

For more information on options and format codes, see “Add Item to 
Menu” on page 582 in chapter 12, The Telelogic Tau Public Interface.

Option Explanation/Value

ItemName A string that contains the menu item text that appears in 
the menu item. Ampersand syntax is supported, as for 
menu names. Make sure that different letters are select-
ed for each menu item in the menu; otherwise keyboard 
activation of the menu item may not work.

Separator A boolean value (0 or 1) that indicates whether a sepa-
rator (a thin line) should precede the menu item in the 
menu.

StatusbarText A string that should be displayed in the tool’s status bar 
while the menu item is selected to hint you about the 
function of the menu choice.
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ProprietaryKey An integer whose interpretation depends on the tool; the 
Organizer interprets this parameter as lastAction, and 
the graphical editors interpret it as ProprietaryKey. 
For more information, see “lastAction” on page 587 and 
“ProprietaryKey” on page 592 in chapter 12, The Tele-
logic Tau Public Interface.
For the Organizer, you can use either an integer or a 
symbolic string as the value.
If not used, simply set to 0.

AttributeKey An integer whose interpretation depends on the tool; the 
graphical editors interpret this parameter as At-
tributeKey. For more information, see “At-
tributeKey” on page 592 in chapter 12, The Telelogic 
Tau Public Interface.
If not used, simply set to 0.

Scope An enumerated value that indicates when the menu item 
should be dimmed. For the valid values, see “scope” on 
page 583 in chapter 12, The Telelogic Tau Public Inter-
face. You can use either an integer or a symbolic string 
as the value.
If not used, simply set to 0.

ConfirmText A text string that contains a dialog box text. If not emp-
ty, this will issue a two button dialog with OK and Can-
cel buttons and an editable text field containing the 
command to be performed. You can alter the command 
text before pressing OK.

ActionInterpretation An integer value indicating the desired action when a 
menu item is activated:
PM_MESSAGE (0) - send PostMaster message
OS_COMMAND (1) - execute OS command

BlockCommand Only significant if Action is set to 1:
A boolean value (0 or 1) indicating whether the Orga-
nizer should wait for the execution of the command to 
complete (1), or allow you to perform other operations 
while the command executes (0).

Option Explanation/Value
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[MENUEND] Section

The [MENUEND] section indicates that a menu definition has come to an 
end and that no more [MENUITEM] sections should appear until a new 
[MENU] section is encountered. This section has no options.

Example of a Menu Definition File
An example of a typical menu-definition file could be:

SDT-DYNAMICMENUS-3.6
[MENU]
Name=&RCS
[MENUITEM]
ItemName=Check &Out
Separator=0
StatusbarText=Check out the selected object
ProprietaryKey=1
AttributeKey=0
Scope=SELECTED_OBJECT_NOT_IN_EDITOR
ConfirmText=
ActionInterpretation=OS_COMMAND
BlockCommand=1
FormattedCommand=co %f
[MENUEND]

FormattedCommand Only significant if Action is set to 1:
The OS command to perform. Some tools evaluate spe-
cific context sensitive format codes.

MessageNumber Only significant if Action is set to 0:
Indicates the number of the PostMaster message to 
send.

FormattedMessage Only significant if Action is set to 0:
The parameters to the PostMaster message. Some tools 
evaluate specific context sensitive format codes.

Option Explanation/Value
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General Quick-Buttons
If you hear a beep when you click a quick-button, then the operation is 
currently not available.

The following quick-buttons can be considered as standard buttons that 
are available in many Telelogic Tau tools:

Back
The same as Back in the Diagrams menu.

Forward
The same as Forward in the Diagrams menu.

Open
The same as Open in the File menu.

Save
The same as Save in the File menu.

Print
The same as Print in the File menu.

Search
The same as Search in the Tools menu.

Search Again
The same as Search Again in the Tools menu.

Show Organizer
Raises the parent Organizer window, from where the tool was started.
In a sub window to a tool, this button raises the main window of the tool.

Decrease Scale
Decrease the scale of the drawing area by 20%.

Increase Scale
Increase the scale of the drawing area by 20%.

Help
The same as On <Tool> in the Help menu.
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The Drawing Area

Popup Menus
You invoke a popup menu with the right mouse button. A menu choice 
in a popup menu generally have the same name and work in the same 
way as a corresponding menu choice in the menu bar. 

There are two types of popup menus: context sensitive popup menus 
and the background popup menu.

Context Sensitive Popup Menus

Objects visible in the drawing area may have associated popup menus, 
whose contents may vary with the type of the object.

In the SDL suite, a context sensitive popup menu can be displayed in 
two slightly different ways:

• By a right-click directly on a visible object.

The current selection also changes with this operation, i.e. the object 
pointed at becomes selected and replaces any previous selection. 

• By a right-click on the background, outside any object, when there 
exists a current selection.

In this case, the popup menu applies to the selected object(s) and the 
selection does not change.

In the TTCN suite, the popup menu always applies to the object the 
mouse pointer is placed on, but the current selection does not change. 
If you right-click on the background of the drawing area, outside of any 
visible object, the background popup menu is displayed, regardless of 
any current selection.

The Background Popup Menu

In the SDL suite, the background popup menu is displayed if you right-
click on the drawing area background, and there is no current selection 
in the drawing area. This popup menu contains some of the most impor-
tant and/or commonly performed menu choices from the menu bar. The 
popup menu choices operate on the whole file, document or drawing ar-
ea, in the same way as the corresponding menu choices from the menu 
bar do.
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In the TTCN suite, the background popup menu is always displayed if 
you right-click on the drawing area background, regardless of any se-
lected objects.

List and Tree Structures
Many Telelogic Tau tools can present a hierarchical structure in two 
ways; as a list structure and as a tree structure. The example below is 
from the Organizer. 

It is possible to switch between the two structures if you select an Op-
tion menu choice on the View menu. It is also possible to collapse and 
expand nodes in a hierarchical structure with the Expand and Collapse 
commands in the View menu. A collapsed node is indicated by a small 
triangle below the node:

Figure 4: List and tree structures

Figure 5: Collapsed nodes in list structure

List 
structure:

Tree 
structure:
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Selections and Input Focus in the TTCN Suite 
(on UNIX)
In the TTCN suite on UNIX there is a difference between selection and 
input focus. Selection is a marked item or text string. You select items 
with the left mouse button. The input focus is set when you point to an 
item and click with the middle mouse button. The input focus is indicat-
ed by a rectangular border surrounding the relevant item. 

Figure 6: Selection and input focus in the TTCN suite on UNIX
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Dialog Windows
There are two types of dialogs, modeless and modal. A modeless dialog 
does not prevent you from using other parts of the application while the 
dialog is visible. A modal dialog does prevent this, that is, the dialog 
must be dealt with before any work can continue.

Modeless Dialogs
A modeless dialog can be considered as an extension to the main win-
dow. It contains an Apply button which executes the functionality of the 
dialog but does not close it. The button is often renamed to indicate the 
functionality, for example Search. The Close button closes the dialog 
but does not apply any functionality.

Modal Dialogs
A modal dialog is used for operations that must be confirmed or that af-
fect the view or the information used in the tool. A typical example is 
an Open dialog. The OK button in a modal dialog both executes the 
functionality and closes the dialog. The Cancel button closes the dialog 
but the settings you may have changed in the dialog are ignored.

File Name Completion
Wherever you are supposed to input a file or directory name as text in a 
text field in a dialog, you can take advantage of file name completion. 
To do this, you type the beginning of an absolute file name or a directo-
ry and then press <Space>. This will add characters at the end of the 
text field. If there are several matches, the initial characters of the 
matching names will be added. Then you have to press <Space> again 
to get the alternatives one by one. And after the final alternative, you 
will get a space character. 

File name completion is not provided in the TTCN suite.

Note:

There is no button with the functionality of an OK button, i.e. exe-
cute the functionality and close down the dialog.
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Example 1: File name completion––––––––––––––––––––––––––––––

Suppose you have the files /home/lat/hello.txt and 
/home/lat/henderson.txt. 

1. Type /home/l, and then press <Space>.

The result will be /home/lat/. 

2. Then type an additional h, and then press <Space> again.

The result will be /home/lat/he. 

3. Press <Space> again.

The result will be /home/lat/hello.txt. 

4. Press <Space> again.

The result will be  /home/lat/henderson.txt. 

5. Press <Space> again.

The result will be  /home/lat/he  (with a space character at the 
end).

––––––––––––––––––––––––––––––––––––––––––––––––––––––––––

Folder Button
When the name of a file or directory is to be specified in a dialog, a com-
bination of a text field and a folder button is often used. You can type 
the name directly in the text field, or press the folder button to open a 
file or directory selection dialog (see the following subsections).

Figure 7: Folder buttons for selecting files and directories (Windows and UNIX)
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File Selection Dialog
When you are going to save or open (or something similar) a file, a file 
selection dialog will be issued. The dialog will also be opened if you 
click on the folder button associated with a file name field in a dialog.

In Windows, the file selection dialog looks and behaves exactly like the 
normal file selection dialog used in Microsoft Windows.

In the SDL suite on UNIX, the file selection dialog behaves like de-
scribed below. The the TTCN suite version on UNIX is described in 
“The TTCN Suite File and Directory Dialog (on UNIX)” on page 31.

• The text in the Filter field determines which files are shown in the 
Files list. The field is initially set to match the file type that the in-
voking tool or dialog operates on but you may change it.

• If you click the Filter button, the file matching pattern in the Filter 
text field is applied to the current directory in the Directories list 
and the Files list is updated. This is the same as pressing <Return> 
or clicking the default button when no file name is present in the 
File text field.

• If you click the Current button, the directory will be changed to the 
source or target directory, depending on which kind of operation 
you have initiated. For more information, see “Set Directories” on 
page 70 in chapter 2, The Organizer. The Files list will be updated 
accordingly. 

• The Directories list shows the absolute path to the currently chosen 
directory, as well as the names of any subdirectories in that directo-
ry. The directories in the path are shown within brackets, slightly in-
dented for each directory level. The last directory in the list is the 
name of the currently chosen directory. To change to another direc-
tory, double-click on any directory in the list. Both the Directories 
list and the Files list are then updated to show the contents of the 
new directory.

• The Files list shows the files in the currently chosen directory that 
match the pattern in the Filter text field. You can select the file to 
operate on from this list, in which case the File text field is updated 
to contain the name of the file. To double-click on a file name is the 
same as selecting it and then pressing the default button.
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• The File text field contains the name of the file selected in the Files 
list. This field may initially contain a default file name, suggested 
by the invoking tool or dialog. You can enter any file name in this 
field, including a relative or absolute path. You may also specify 
paths to home directories with the “tilde” syntax (~/ or ~user/).

When <Return> or the default button is pressed, it is the file in this 
text field that is operated on. If the field is empty and no file is se-
lected in the Files list, this is the same as pressing the Filter button.

Directory Selection Dialog
A directory selection dialog is opened when you select menu choices 
dealing with directories. The dialog will also be opened if you click on 
the folder button associated with a directory name field in a dialog.

In Windows, the directory selection dialog looks and behaves exactly 
like the normal directory selection dialog used in Microsoft Windows.

In the SDL suite on UNIX, the directory selection dialog behaves like de-
scribed below. The TTCN suite version on UNIX is described in “The 
TTCN Suite File and Directory Dialog (on UNIX)” on page 31.

• The Directories list works in the same way as in the file selection 
dialog. It is the last directory in the indented list of directories that 
is chosen when the OK button is pressed, unless the text field is 
specified. This means that it is not enough to select a directory in the 
list; it has to be double-clicked to become the chosen directory.

• The Text Field may be used to enter any directory name, including 
a relative or absolute path. When <Return> or the OK button is 
pressed, it is the directory in this text field that is chosen, if it is spec-
ified.

• The Current button works in the same way as in the file selection 
dialog. For more information, see “File Selection Dialog” on page 
30.

The TTCN Suite File and Directory Dialog (on 
UNIX)
Many TTCN suite dialogs on UNIX require the specification of directory 
paths and file names. A special dialog is used for this purpose.
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The example used in the description of the dialog below is taken from a 
Log file dialog, but the principle is the same for all file/directory orient-
ed dialogs.

• The Filter field enables you to specify a name pattern which will 
cause only those file names which match the pattern to be displayed 
in the Files list. Note that the name pattern must be preceded by the 
complete directory path. This path is set by the TTCN suite to the 
currently selected directory (by selecting a directory path in the di-
rectories list), but you may edit it directly.

• The Directories list shows the directories in the current directory. 
This list will contain at least two entries, the current directory (a 
path ending in /.) and the parent directory (a path ending in /..). 
To change to another directory in the dialog, select the required di-
rectory path and double-click (see also the Filter command).

• The Files list shows the files that are in the selected directory which 
match the name pattern. If no files match the pattern or the directory 
is empty, this is indicated by “[ ]”.

Figure 8: The TTCN suite file and directory dialog (on UNIX)
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• The Selection field displays the currently selected file. This input 
field also enables you to directly type in a file name.

• The Filter button updates the Files list depending on the filter pat-
tern (including the file path). Select a directory in the Directories 
list, then choose the Filter button to open the directory and display 
the files in that directory (if any) in the Files list.

• The Select button terminates the dialog with the selection indicated 
in the Selection input field (in other dialogs this button may have an-
other name, e.g. Open, Export, etc. but the effect is the same). If 
there is already a file name chosen before invoking this dialog (i.e. 
from import dialog when selecting a database name) and no name is 
specified in the Selection input field in this dialog, only the directory 
path will be modified.

Filename Error Dialogs (UNIX only)
For compatibility reasons, file names on UNIX platforms must not con-
tain colon characters. For an overview on file compatibility issues, see 
“Windows and UNIX File Compatibility” on page 209 in chapter 2, The 
Organizer.

In the SDL suite, this restriction is checked whenever the you change a 
file or directory specification that is stored in the system file (see “Sys-
tem File” on page 184 in chapter 2, The Organizer for more informa-
tion). If they are not followed, an error dialog is shown and you are re-
turned to the dialog where the file was specified.

If you use the TTCN suite, this restriction affects you only when you 
choose a name for the system file in the Organizer.

The Busy Dialog
In some special circumstances, a message dialog may be opened, stating 
that a tool is “busy.” This is not an indication of a system error. The di-
alog is opened when a tool is busy performing an operation that you 
have not finished. A typical example is when you select Show Organiz-
er from another tool, and you have not closed a modal dialog in the Or-
ganizer, for example the Print dialog.

The remedy for a situation like this is to close the message dialog and 
finish the operation that caused the busy message.
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The Timeout Warning
When a Telelogic Tau tool is started on a heavily loaded computer sys-
tem, it may fail to start and respond within a certain time limit. When 
this happens, a timeout warning dialog is opened.

The time limit is specified, in seconds, by the environment variable 
STARTTIMEOUT. The default time limit is 60 seconds. If timeout prob-
lems occur, this variable should be adjusted to a higher value to match 
the typical response times for the computer system where the Telelogic 
Tau tool is running. For the changed time limit to take effect, the Tele-
logic Tau tools must be restarted.
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Keyboard Operations
It is possible to reach and invoke all commands, menu choices and se-
lections by using the keyboard. This section describes the general key-
board operations available.

Menu Traversal
The name of each menu in the menu bar contains an underlined charac-
ter, as in the menu name File. To display, or pull down, the menu, press 
<Meta> (on UNIX) or <Alt> (in Windows) and the corresponding key, 
for example <Meta+F> or <Alt+F>.

One character in each menu choice is also underlined. To invoke a menu 
choice when the menu is displayed, simply press the corresponding key. 

The arrow keys can also be used to move between the menu choices and 
the adjacent pull-down menus.

To invoke a selected menu choice, press <Return> or <Space>. To 
cancel the menu traversal and bring down the menu, press <Esc>.

Keyboard Accelerators
You can invoke most common menu choices by using an accelerator. 
An accelerator is a key combination of the form Ctrl+X. An accelera-
tor is always case insensitive.

An accelerator always invokes the same kind of command in all SDL 
suite tools where it is available. The standard accelerators are:

Accelerator Functionality or menu command

Ctrl+F Find, Search (in the Tools menu)

Ctrl+H Help (On <tool> in the Help menu)

Ctrl+N New (in the File menu)

Ctrl+O Open (in the File menu)

Ctrl+P Print (in the File menu)

Ctrl+Q Quit, Exit (in the File menu)

Ctrl+S Save (in the File menu)
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Key Bindings
By using some special keys, you may perform an operation without 
holding down any modifier key at the same time.

Ctrl+X Cut (in the Edit menu)

Ctrl+C Copy (in the Edit menu)

Ctrl+V Paste (in the Edit menu)

Ctrl+Z Undo (in the Edit menu)

Ctrl+D Scroll one page down

Ctrl+U Scroll one page up

Note:

All keys are not present on all keyboards.

Key Operation

Arrow keys Moves the selection in tree structures, list struc-
tures and ordinary lists to the closest object in the 
indicated direction.

Return 
(Enter)

• In a drawing area: the same action as a dou-
ble-click on the selected object.

• In a dialog: the same action as pressing the 
default button.

Delete 
(Remove)

For texts, clears the character after the insertion 
point. (May be changed with a preference.)

Backspace For texts, clears the character before the insertion 
point.

F1 / Help Opens the help viewer with help on the current 
window.

F2 Raises the popup menu.

Page Up 
(PgUp, Prev)

Moves the visible part of the drawing area a 
screen upwards.

Accelerator Functionality or menu command
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Key Bindings in the TTCN Suite
More information on keyboard accelerators and key bindings in the 
TTCN suite can be found in:

• “Shortcuts” on page 1269 in chapter 31, Editing TTCN Documents 
(in Windows)

• “Key and Button Bindings” on page 1155 in chapter 25, The TTCN 
Browser (on UNIX)

• “Key and Button Bindings” on page 1179 in chapter 26, The TTCN 
Table Editor (on UNIX)

• “Customizing the TTCN Suite (on UNIX)” on page 1227 in chapter 
30, Customizing the TTCN Suite (on UNIX)

Page Down 
(PgDn, Next)

Moves the visible part of the drawing area a 
screen downwards.

Home Moves the visible part of the drawing area to 
show the top of the drawing area.

End Moves the visible part of the drawing area to 
show the bottom of the drawing area.

Open As the menu choice Open.

Find As the menu choice Search.

Again As the menu choice Search Again.

Undo As the menu choice Undo.

Copy As the menu choice Copy.

Paste As the menu choice Paste.

Cut As the menu choice Cut.

Key Operation
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