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Chapter
26 The TTCN Table Editor 

(on UNIX)
This chapter contains reference information about the Table Edi-
tor, used for editing various TTCN tables.

The functionality of the Table Editor, the menus, windows and 
quick-buttons are described in this chapter. The TTCN Browser is 
described in chapter 25, The TTCN Browser (on UNIX). How to an-
alyze and find tables is described in chapter 27, Analyzing TTCN 
Documents (on UNIX).

For an overview of the TTCN suite, see chapter 3, Introduction to 
the TTCN Suite (on UNIX), in the TTCN Suite Getting Started.

Note: UNIX version

This is the UNIX version of the chapter. The corresponding 
Windows chapter is chapter 31, Editing TTCN Documents (in 
Windows).
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Chapter 26 The TTCN Table Editor (on UNIX) 
Introduction to the TTCN Table Editor
The Table Editor is used for editing the various TTCN tables. It is pos-
sible to have any number of tables open for editing at any given time.

The TTCN suite supports all of the standardized, non-compact tables 
that are defined in ISO/IEC 9646-3. The compact Test Case Dynamic 
Behaviour table (ISO/IEC 9646-3, clause C.3) and the concurrent 
TTCN tables are supported, as well as the modular TTCN tables to be 
added in the upcoming new TTCN version.

The compact tables for constraints (also in Annex C of 
ISO/IEC 9646-3) are not supported.

On screen, the TTCN suite presents all tables exactly as defined in 
ISO/IEC 9646-3, apart from some minor additions to the regular dy-
namic behaviour tables (for test cases, test steps and defaults), to the 
compact test case dynamic behaviour table, to the ASN.1 type by refer-
ence tables, to the test suite constant declarations by reference, and to 
the import tables.

These changes have been introduced to aid the automatic generation of 
the TTCN document overview and index tables. For more information, 
see “Generating the Test Suite Overview Tables” on page 1151 in chap-
ter 25, The TTCN Browser (on UNIX). However, in the printed GR form 
the TTCN document is presented according to the ISO standard (that is, 
the additions are not present in the printed version).

As a visual aid, dotted lines separate rows in a table. Again, this is not 
present in the printed GR form.

The TTCN suite always displays the optional comments column and 
comments footer of a table, even if they are empty.

You can use both menu choices and keyboard shortcuts for editing ta-
bles. It is also possible to search and replace text patterns. By providing 
a Data Dictionary, the Table Editor supports semi-automatic generation 
of send and receive statement lines. In the Data Dictionary, you select 
the components in a send or receive statement from lists of PCOs, types 
and constraints. The TTCN suite prevents you from selecting incompat-
ible items.

The Table Editor also shows the analysis status of the table contents.
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 Opening a Table
Opening a Table
Tables are opened from a Browser when you double-click on a selected 
table name, or with the popup menu. For more detailed information see 
“Opening a Table” on page 1114 in chapter 25, The TTCN Browser (on 
UNIX).

Renaming a Table
A table can be renamed either by using the Rename command in the 
Browser (for more information see “Renaming Dynamic Items” on 
page 1113 in chapter 25, The TTCN Browser (on UNIX)) or by editing 
the table name in the table itself. This choice also exists for objects in 
multiple-object tables.

Figure 206: A TTCN Table Editor for a test case
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Navigating and Editing Text in a Table
The Table Editor facilitates fast and efficient editing. The input focus 
determines which field is open for editing at any given time.

Setting the Input Focus
The input focus is automatically set on the name field of the table when 
it is opened. Reset the input focus by using the following shortcuts:

You can also use the mouse for setting the input focus. However, note 
that a middle-click only moves the focus to that field but it is not possi-
ble to edit text. To do this, you have to left-click in the field.

Editing Text in a Table
To edit the text in a field, you set the input focus and start typing. The 
table fields will expand automatically to accommodate the text and you 
can add a line break by simply pressing <Return>. To move the inser-
tion point in the same field, you can either use the mouse or the follow-
ing shortcuts:

To move to: Use this key combination:

Next field <Tab>

Previous field <Shift+Tab>

Next part of the table <Ctrl+Tab>

Next field in same column <Ctrl+down arrow>

Previous field in same column <Ctrl+up arrow>

Field on the left <Ctrl+left arrow>

Field on the right <Ctrl+right arrow>

To move the insertion point: Use this key combination

Down <Ctrl+N>, <down arrow>

Up <Ctrl+P>, <up arrow>

Left <Ctrl+B>, <left arrow>
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If you initially type with very high speed, race problems may arise and 
you will be notified with a beep. This means that the text typed in will 
not appear correct in the buffer. If this happens often, you should make 
a brief pause between typing the first and consecutive characters.

Cut, Copy and Paste Text

To cut, copy and paste text in the fields, you can use the following short-
cuts. Note that you do not use the same commands or shortcuts as when 
editing entire rows in a table.

Right <Ctrl+F>, <right arrow>

To the beginning of the line <Ctrl+A>

To the end of the line <Ctrl+E>

Left and extending selection <Shift+left arrow>

Right and extending selection <Shift+right arrow>

To do this: Use this key combination:

Delete one character forward <Ctrl+D>

Cut selected text <Cut>, <Shift+Delete>

Cut text to the end of the line <Ctrl+K>

Copy selected text <Copy>, <Ctrl+Insert>a

a. <Ctrl+Shift+Insert> also works.

Paste cut or copied text <Paste>, <Shift+Insert>

Paste the most recently cut line <Ctrl+Y>

Note:

The paste buffer for text is not the same as the one used for entire 
rows in the body of a table.

To move the insertion point: Use this key combination
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Caution!

The TTCN suite has no undo function. This means that <Undo> has 
no effect.
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 Editing Rows in a Table
Editing Rows in a Table
Rows can be added, deleted, copied, etc. in the bodies of all TTCN ta-
bles that contain more than one column. The ASN.1 tables only have a 
single column with a single row and therefore adding, deleting and 
copying rows is not applicable. However, you can still copy and paste 
the contents of these tables as text.

You cannot add or remove rows in table headers and footers, as the for-
mats of these parts of a table are defined by the TTCN standard.

Selecting Rows in a Table
In the dynamic behaviour tables, you select a single row by clicking the 
row number. 

You select a behaviour tree of rows by <Ctrl+Shift>-clicking.

You select rows in the body of a table by <Ctrl>-clicking. Selecting a 
row does not deselect other selected rows.

To deselect a row, you select it again.

Cutting, Copying and Pasting Rows
Rows in a table may be cut, copied and pasted. This not only possible 
among tables of the same or similar type, but also across different types 
of tables.

Edit > Cut

Edit > Copy

Note:

Setting the input focus will also deselect all selected rows.

Removes selected row or rows from the table and stores them in the 
clipboard.

Copies selected rows to the paste buffer. Any number of rows may be 
selected.
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Edit > Delete

Deletes the selected row or rows.

Inserting Rows

Edit > Insert Row

Edit > Insert Row After

Edit > Insert Tree Header

Inserts a new Tree Header row before a selected row. Only one row may 
be selected. This command only works in dynamic behaviour tables.

Edit > Insert Tree Header After

Inserts a new Tree Header row after a selected row. Only one row may 
be selected. This command only works in dynamic behaviour tables.

The <Ins> Key

The <Ins> key (on the right-hand keypad) can be used for inserting 
rows. If you press this key while input focus is in the header or footer of 
a table, a new row is appended after the last row in the body of the table. 
If the input focus is set on a field in the body of the table, <Ins> will 

Note:

The paste buffer used for entire rows in the body of a table, is not the 
same as the one used for text.

Caution!

The TTCN suite has no undo so this command is irreversible.

Inserts a new row before a selected row. Only one row may be selected.

Inserts a new row after a selected row. Only one row may be selected.
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insert a new row after the field that has the input focus. The input focus 
will be transferred to the corresponding field in the new row.

Indenting Rows in Behaviour Descriptions
TTCN behaviour tables include a number of commands and shortcut 
keys that simplify indenting behaviour lines.

Edit > Increase Indent

• Keypad <+>
Pressing <+> (Plus) on the right-hand keypad (the normal <+> key 
does not have this effect) will indent the field that currently has the 
input focus.

• <Ctrl> + Keypad <+>
Pressing <Ctrl> together with the keypad <+> key will cause se-
lected behaviour lines to be indented one position, i.e. it has the 
same effect as the Increase Indent command.

• <Shift> + Keypad <+>
Pressing <Shift> together with the keypad <+> key will cause an 
entire branch in the behaviour tree to be indented one position.

Edit > Decrease Indent

• Keypad <->
Pressing <-> (Minus) on the right-hand keypad (the normal <-> 
key does not have this effect) will undent the field that currently has 
the input focus.

Caution!

Do not use the <Tab> character to represent indentation in behav-
iour trees.

Increases the indentation of selected behaviour lines by one position. 
This command can only be used to indent behaviour lines.

Decreases the indentation (i.e. undent) of the selected rows by one po-
sition. This command can only be used on behaviour lines.
July 2003 Telelogic Tau 4.5 User’s Manual ,um-st1 1167



Chapter 26 The TTCN Table Editor (on UNIX) 
• <Ctrl> + Keypad <->
Pressing <Ctrl> together with the keypad <-> key will cause se-
lected behaviour lines to be undented one position, i.e. it has the 
same effect as the Decrease Indent command.

• <Shift> + Keypad <->
Pressing <Shift> together with the keypad <-> key will cause an 
entire branch in the behaviour tree to be undented one position.

Selecting Branches in Behaviour Descriptions
TTCN behaviour tables include the following short-cut key that simpli-
fies the task of selecting behaviour lines.

• <Shift+Ctrl> + Left Mouse Button
Pressing <Shift+Ctrl> together with the left mouse button while 
the cursor is pointing to a behaviour line, will select that behaviour 
line and all the subsequent behaviour lines that are in the same 
branch of the behaviour tree.

Showing the Indentation Level

Show > Show Indent

Causes the indentation level of behaviour lines to be displayed in the 
line number column of behaviour tables. Choosing this command again 
will cause the display to revert to line numbering.

Searching and Replacing
From the Table Editor, you can search for and replace text, either on 
system, document or table level. You specify the search in the search 
bar of the Table Editor and start the search (and replace) from menu 
choices in the Search menu.

Figure 207: The TTCN Table Editor search bar
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Specifying Search and Replace Settings

Delimiting the Scope of Search

You can search for text on three levels:

• System means all documents of the associated document – except 
for any Flat View document – or only the associated document if it 
is a Flat View.

• Document means the associated document only.

• Table means the current table only.

Selecting the Type of Search

There are three types of search patterns:

• Text means ordinary literal strings.

• Wildcard means a pattern with * and ?.

• Regular Exp means regular expression.

See also “Regular Expressions” on page 1123 in chapter 25, The 
TTCN Browser (on UNIX).

Selecting the Search Direction

The search direction can be forward (down arrow) or backward (up ar-
row).

Specifying the Text to Search For

You specify the text to search for in the Look for field. If you search for 
text using a regular expression, you will be notified if you try to use an 
incorrect regular expression.

Specifying the Replacement Text

You specify the replacement text (or replacement pattern, if the type of 
search is regular expression) in the Change to field.

If you search and replace using regular expressions, the replacement 
pattern must be compatible with the search pattern. If it is not, you will 
be notified. 
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Something important to note about regular expressions, is that the actual 
replacement text is a result of a combination of the search pattern, the 
match found and the replacement pattern. This means that the actual re-
placement text may not literally match the text in the Change to field. 
However, the actual replacement text will be presented in the status bar 
when you start searching and a match is found.

Starting the Search and Replace

Search > Search

Search > Replace

You can also replace manually selected text. This only requires that 
Text or Wildcard is selected and that the Change to field contains some 
text. Note that you cannot manually make an empty selection, but it is 
possible to search and find an empty match that you can replace.

Search > Proceed

Search > Replace All

Starts the search from the current position. If you search in the current 
table, selected text will be skipped. If the Table Editor is empty, the 
search will start from the beginning or end of the document or system, 
depending on the scope and direction that you have specified.

Replaces currently selected text with the replacement text. If you 
searched using regular expressions, the replacement text will be pre-
sented in the status bar when a match is found.

Searches for and replaces text sequentially. If text is selected, it will be 
replaced and after that the search will proceed.

Replaces selected text and then continues the search and replace from 
the current position. If the Table Editor is empty, the search will start 
from the beginning or end of the document or system, depending on the 
scope and direction that you have specified. The number of replace-
ments will be presented in the status bar.
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 Exporting and Importing Objects
Exporting and Importing Objects
Generate Exports and Generate Import assist in the use of the Modular 
TTCN feature of exporting and importing objects to and from other doc-
uments.

Tools > Generate Exports

Fills the TTCN Exports table with rows that provide access to the ob-
jects of the current document. Only rows that are not already present 
will be added (at the end of the table), so it is supported to repeat this 
operation at a later time to detect if any object has been added since the 
last time. Generate Exports is only available when the Table Editor con-
tains a TTCN Exports table.

Tools > Generate Import

Fills the Import table with rows that enables access to the objects of the 
document to import from. Only rows that are not already present will be 
added (at the end of the table), so it is supported to repeat this operation 
at a later time to detect if any object has been added since the last time. 
Generate Import is, naturally, only available when the Table Editor 
contains an Import table.

Browsing in the Table Editor
With the Previous Table and the Next Table commands, you can easily 
browse the contents of the TTCN document.

File > Previous Table

File > Next Table

See also “Context Sensitive Popup Menu” on page 1177 and “Finding 
Tables by Name” on page 1196 in chapter 27, Analyzing TTCN Docu-
ments (on UNIX).

Replaces the table shown in the Table Editor with the previous table in 
the document. To open the table five tables before the current, use 
<Ctrl> + Previous Table.

Replaces the table shown in the Table Editor with the next table in the 
document. To open the table five tables after the current, use <Ctrl> 
+ Next Table.
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Generating Behaviour Statements
In TTCN behaviour tables it is possible to get lists of user defined ob-
jects (e.g. constraints, timers etc.). Through these lists, you can generate 
a statement.

When you invoke the following commands, a row in the table should 
have the input focus.

Data Dictionary > Add Send Statement

Each list is split in two parts. The upper part contains the items corre-
sponding to the selected items in the other lists. The lower part contains 
the rest of the items.

Generate a Send statement by selecting a PCO, a type and a constraint.

This functionality requires that the TTCN document is analyzed. The 
PCOs, types and constraints with major reference problems or missing 
type references will not be presented in these lists.

Figure 208: Add Send statement dialog (receive is analogous)
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• PCOs

Select a PCO or CP in this list and the Types and Constraints lists 
will be split accordingly.

• Types

Select an ASP, PDU or CM type in this list and the corresponding 
constraints and PCOs lists will be split accordingly.

• Constraints

Select a constraint in this list and the corresponding Types and 
PCOs will be split accordingly.

• Open

The selected constraint will be opened.

• New

A new constraint of the selected type is created. The new constraint 
will be opened.

• Copy

A new constraint which is a copy of the selected constraint is creat-
ed. The new constraint will be opened.

• Refresh

Recompute the contents of the lists and re-display the dialog. The 
selection will be preserved.

• Parameters

If the selected constraint has a parameter list, an actual parameter 
list is specified here.

• OK

A Send statement is generated with the selected PCO (or CP), type 
and constraint.
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Data Dictionary > Add Receive Statement

A dialog which is analogous with Add Send Statement will be displayed.

Data Dictionary > Add StartTimer Statement

Generate a StartTimer statement by selecting a timer.

• When OK is clicked, a StartTimer statement is generated with the 
selected timer.

Data Dictionary > Add CancelTimer Statement

Generate a CancelTimer statement by selecting a timer.

A dialog which is analogous with Add StartTimer Statement will be dis-
played.

Generate a Receive statement by selecting a PCO, a type and a con-
straint.

Figure 209: Add StartTimer Statement dialog
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Data Dictionary > Add Attach Statement

Generate an Attach statement by selecting a test step and specifying an 
actual parameter list (if the test step has a formal parameter list).

Data Dictionary > Add Timeout Statement

Generate a Timeout statement by selecting a timer.

A dialog which is analogous with Add StartTimer Statement will be dis-
played.

Figure 210: Add Attach Statement dialog
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Reverting a Table

File > Revert

Causes all edits to the table since it was last opened to be discarded. In 
other words, the contents of the table are restored to what they were at 
the point when the table was opened.

This gives the TTCN suite a limited undo capability. Note that the an-
alyze status of the table may be set to not analyzed by this command.

Creating a New Constraint Table
The Create Constraint and Copy Constraint commands, facilitate the 
creation of Constraint tables:

Tools > Create Constraint

Creates a new Constraint table – related to the Type table currently 
shown in the Table Editor – in a new Table Editor window.

If you use <Ctrl> + Create Constraint, the new Constraint table will 
instead be shown in the current Table Editor.

Tools > Copy Constraint

Creates a new Constraint table – that is an exact copy of the Constraint 
table currently shown in the Table Editor – in a new Table Editor win-
dow.

If you use <Ctrl> + Copy Constraint, the new Constraint table will 
instead be shown in the current Table Editor.

Generating the Test Suite Overview Tables
The generation of Test Suite Overview Tables is described in “Generat-
ing the Test Suite Overview Tables” on page 1151 in chapter 25, The 
TTCN Browser (on UNIX).
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Using Popup Menus
The background popup menu is accessible when you click the right 
mouse button. When you click the right mouse button and <Ctrl>, the 
context sensitive menu will be available.

Context Sensitive Popup Menu
The context popup menu contains only one operation, Find Table, but 
in addition it also contains some of the content of the table to be opened 
by this Find Table operation. The identifier to use in the Find Table op-
eration is retrieved from the field content under the mouse pointer when 
the context menu was invoked.

Background Popup Menu
The background popup menus are available in all the TTCN suite tables 
but the appearance differs in accordance with the applicable operations. 
The popup menus in synchronized behaviour tables and desynchronized 
behaviour tables have a totally different appearance and will be de-
scribed below:

Synchronized Behaviour Tables

If the Table Editor contains a behaviour table which is synchronized, 
the popup menu will display the same menu entries as the SDT Link 
menu. For an explanation of synchronized and the commands in the 
SDT Link menu see chapter 36, TTCN Test Suite Generation.

Desynchronized Behaviour Tables

If the Table Editor contains a behaviour table which is not synchro-
nized, the popup menu will have a different appearance than in the pre-
vious case.

Figure 211: Example use of the TTCN Table Editor context popup menu
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The popup menu will contain a sub menu containing all the menu en-
tries of the Data Dictionary pull-down menu. It will also contain the fol-
lowing entries:

Cut Focused Row

Removes the focused row from the table and stores it in the clipboard.

Copy Focused Row

Copies the focused row to the paste buffer.

Paste Before Focused Row

Pastes the contents of the paste buffer before the focused row.

Delete Focused Row

Deletes the focused row.

Increase Indent

Increases the indentation of the focused behaviour line by one position. 

Decrease Indent

Decreases the indentation of the focused behaviour line by one position.

Increase Sub Tree Indent

Increases the indentation of an entire branch in the behaviour tree by 
one position starting from the focused row.

Decrease Sub Tree Indent

Decreases the indentation of an entire branch in the behaviour tree by 
one position starting from the focused row.

Insert Row After

Insert a new row after the focused row.

Show Error Message

Displays the analysis status message (if any) of the focused field.

Find Table

Finds a named table.
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Key and Button Bindings
Some bindings operate on the body rows as if they were organized as a 
tree (work only in the dynamic part of the TTCN document). The inden-
tation level defines the tree structure.

Key Action

osfUp Move focus to a neighbor field.

osfDown Move focus to a neighbor field.

osfRight Move focus to a neighbor field.

osfLeft Move focus to a neighbor field.

Ctrl+osfUp Move focus to a neighbor field even when edit-
ing.

Ctrl+osfDown Move focus to a neighbor field even when edit-
ing.

Ctrl+osfRight Move focus to a neighbor field even when edit-
ing.

Ctrl+osfLeft Move focus to a neighbor field even when edit-
ing.

osfInsert Insert a new row, after focused row if already in 
body, otherwise last in body.

osfHelp Get help on Table Editors.

Ctrl+Z Run “Analyze & Stop” on page 1183 in chapter 
27, Analyzing TTCN Documents (on UNIX)

Ctrl+S Search forward with the current settings

Ctrl+R Search backward with the current settings

character keys Start editing field and then apply key.

Delete Start editing field and then apply key.

... Start editing field and then apply key.

Tab Move focus to a neighbor field.

Shift+Tab Same as <Tab> but in the opposite direction.
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Ctrl+Tab Navigate in the tool bar, the search bar, the scroll 
bars and the table

Ctrl+Shift+Tab Same as <Ctrl+Tab> but in the opposite direc-
tion

Ctrl+space Toggle selection of focused row

KP_Add Increase indentation level of focused row

Ctrl+KP_Add Increase indentation level of selected rows

Shift+KP_Add Increase indentation level of focused subtree

Ctrl+Shift+KP_Add Increase indentation level of subtree of single se-
lected row

KP_Subtract Decrease indentation level of focused row

Ctrl+KP_Subtract Decrease indentation level of selected rows

Shift+KP_Subtract Decrease indentation level of focused subtree

Ctrl+Shift+KP_Subtract Decrease indentation level of subtree of single 
selected row

Ctrl+Shift+osfUp Move focus to previous row at same indentation 
level

Ctrl+Shift+osfDown Move focus to next row at same indentation level

Ctrl+Shift+osfRight Move focus to last child row of focused row

Ctrl+Shift+osfLeft Move focus to parent of focused row

Mouse button (OSF names) Action

Button1 Set focus to the field, and start editing.

Button2 Move focus to the field.

Ctrl+Button1 Toggle selection status of the row

Ctrl+Shift+Button1 Toggle selection status of the subtree with the 
row as root, move the focus to the field under 
pointer

Key Action
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