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Chapter
42 Editing MSC Diagrams
This chapter describes how to create and edit MSCs (Message Se-
quence Charts). 

For a reference to the MSC Editor, see chapter 40, Using Diagram 
Editors. 
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General
Editing Functions
The MSC Editor is the graphical tool that you use to create, edit, print 
and store Message Sequence Charts. The MSC Editor provides, among 
other things, the facility of including MSCs into SDL systems.

The basic editing functionality that the MSC Editor provides can be 
summarized as:

• Creating and managing MSCs
• Appending, moving, resizing symbols
• Interconnecting symbols with lines
• Editing text
• Printing MSCs

Tracing a Simulation
You can also use the MSC Editor as a graphical trace tool, which en-
ables the automatic generation of an MSC from a simulation. The re-
sults of the simulation will be presented in an MSC Editor window, in 
which each event of interest will be appended to the chart in order to 
build up a chart which reflects the history of the simulation. The results 
of a simulation can be saved in MSC/PR form and re-read by the MSC 
Editor.

The commands that start up the logging of MSC events, set up the scope 
of trace, stop the logging of events, and so on, are given to the Simula-
tor. See chapter 51, Simulating a System.

Validating a System
An MSC can be used as a means to express the requirements on an SDL 
system. With the MSC Editor and the Validator, a powerful validation 
environment is provided. The basic idea is to draw an MSC using the 
MSC Editor and then use the Validator to check if there is a possible ex-
ecution path for the SDL system that satisfies the MSC.

The commands that validate a system are given to the Validator. See 
chapter 54, Validating a System.
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Supported MSC Formats
The MSC Editor supports reading MSCs stored in either:

• The MSC/GR format used by the MSC Editor (in which case the de-
fault file extension is .msc)

• The MSC/PR format (stored on MSC/PR files, where the default 
file extension is .mpr)

By default, the MSC Editor stores diagrams in the MSC/GR format, but 
it can also generate MSC/PR for a diagram.

MSC/PR files can be expressed in two forms, event-oriented1 or in-
stance-oriented2. See the Z.120 recommendation for more information 
on these two alternative formats.

Compliance with ITU Z.120

MSC Diagrams
The MSC Editor supports virtually all of the ITU Z.120 language defi-
nition for MSCs, including most of the MSC’96 additions.

For information on the MSC support compared to Z.120, see “Compat-
ibility with ITU MSC” on page 13 in chapter 1, Compatibility Notes, in 
the Release Guide.

Pagination
MSCs cannot be split into multiple pages in the same way as SDL dia-
grams. However, if your MSC requires more than one sheet of paper 
when printing, the MSC Editor takes care of splitting the chart into mul-
tiple parts to print on separate sheets of the paper size you have speci-
fied. You set up the printer pages with the Preference Manager. You can 
use the Window Options menu choice from the View menu to show the 
page boundaries on the screen.

1. Event oriented MSC/PR describes the MSC using the order in which the events 
occur, i.e. starting with the top of the diagram and downwards, providing the 
feeling of a global event order.

2. Instance oriented MSC/PR describes the MSC on an instance by instance basis. 
The feeling of a global event order within the MSC is lost.
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Each part of a multiple-part chart can be printed with adjacent page 
markers to assist you in making up the complete chart. This feature is 
by default disabled and must be set as a preference or specified in the 
Print dialog.

Syntax Rules at Editing Time
Some of the MSC syntax rules are enforced during edit when you ap-
pend symbols and lines to your MSC. These rules determine:

• Which symbols and lines are allowed to be interconnected

• Where symbols can be placed

This syntax checking cannot be disabled. All text is checked during ed-
iting.

Basic Operations

Starting the MSC Editor
In the Organizer, MSCs are handled as references, which you can add 
and remove from any of the Organizer chapters. There are several ways 
you can start the MSC Editor:

• Starting on an Existing MSC Icon
• Starting on an Existing MSC, not Managed by the Organizer
• Starting on an Unconnected MSC Icon
• Starting on a New MSC Icon

Starting on an Existing MSC

To start the MSC Editor on an existing MSC, you either use an MSC 
icon connected to an MSC diagram file, or add a new MSC icon for an 
MSC diagram.
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 Basic Operations
Starting on an Existing MSC Icon

To start the MSC Editor on an existing MSC managed by the Organizer:

1. In the Organizer select the icon that represents an MSC. (The MSC 
icon must be connected to a file.)

– Alternatively, if the MSC is associated with an SDL diagram, 
you can select the associated MSC link icon (looking like an 
MSC icon displayed in dashed form).

2. Start the MSC Editor by the Edit menu choice on the Organizer’s 
Edit menu or by double-clicking the MSC icon.

The MSC Editor window is displayed, the current MSC data is read 
from file and the upper left portion of the chart is displayed.

Starting on an Existing MSC, not Managed by the Organizer

To start the MSC Editor on an existing diagram that is not managed by 
the Organizer (i.e. not contained in the Organizer structure) you must 
first include it into the Organizer, before the MSC Editor can be started.

To include an existing MSC into the Organizer:

1. Select the place in the Organizer where you want to add the MSC. 
The MSC will be added as a new root diagram after a selected doc-
ument or chapter, or at the top level of a selected module.

2. Select Add Existing from the Organizer’s Edit menu.

3. In the dialog that is opened, find and select an MSC diagram file. 
Set the filename filter to *.msc to only list MSCs. The MSC is add-
ed to the Organizer structure, and is opened in the MSC Editor.

If an SDL diagram was selected in the Organizer, an association link 
to the MSC is also added to the SDL diagram.

Figure 322: An MSC icon and an associated MSC icon
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Starting on a New (Nonexisting) MSC

To start the MSC Editor on a new MSC, you either use an unconnected 
MSC icon, or add a new MSC icon.

Starting on an Unconnected MSC Icon

To start the MSC Editor on an existing but unconnected MSC icon:

1. Select an unconnected MSC icon in the Organizer.

2. Open the unconnected MSC by the Edit menu choice on the Orga-
nizer’s Edit menu or by double-clicking the MSC icon. A dialog is 
opened:

3. Make sure the Show in editor option is set. Then click OK to open 
the MSC Editor on the new, empty diagram. 

– You can also change the name of the MSC diagram before it is 
opened.

– To copy the contents of an existing MSC diagram file before 
opening the new diagram in the MSC Editor, select the option 
Copy existing file and enter a filename.

Figure 323: The Edit dialog
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 Basic Operations
Starting on a New MSC Icon

To add a new MSC icon to the Organizer and start the MSC Editor on 
that icon:

1. Select the place in the Organizer where you want to add the MSC. 
The MSC will be added as a new root diagram after a selected doc-
ument or chapter, or at the top level of a selected module.

2. Select Editors > MSC Editor from the Organizer Tools menu. A 
new MSC diagram icon is added to the Organizer structure, and the 
new diagram is opened in the MSC Editor. If an SDL diagram was 
selected in the Organizer, an association link to the MSC is also add-
ed to the SDL diagram.

– Alternatively, select Add New from the Organizer Edit menu. A 
dialog is opened. Select an MSC diagram type, enter a name in 
the New document name field and click OK.

Exiting the MSC Editor
1. Select Exit from the File menu. If the MSC Editor holds any MSC 

that you have modified but not saved, a dialog is issued, prompting 
you to save the changes before the application terminates.

2. The dialog informs you about the name of the diagram in turn to be 
saved. Depending on if you want to save the changes or not:

– Click Save to save changes made to the current diagram. The 
MSC Editor prompts you to save the next modified diagram, al-
ternatively exits if there are no more diagrams to save.

– Click No Save to close the current diagram without saving it. 
The MSC Editor then prompts you to save the next modified di-
agram, alternatively exits if there are no more diagrams to save.

– Click Save All to save all changes made to all diagrams. Once 
all diagrams are saved, the MSC Editor will exit.

– Click Quit All to exit the MSC Editor without saving any MSCs.

– Click Cancel if you want to continue the MSC Editor session.
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Managing MSCs
You create MSCs in the MSC Editor. Once an MSC has been created, 
you may include it into the structure that is managed by the Organizer, 
in order to take full advantage of the functionality that Telelogic Tau 
provides. MSCs can however be handled as separate entities.

The following operations are described in this section:

• Creating an MSC
• Renaming an MSC
• Opening an MSC
• Saving an MSC
• Saving a Copy of an MSC
• Displaying an Opened MSC.

Creating an MSC
You can create MSCs in two ways.

Creating an MSC from the MSC Editor

1. Select New from the File menu. A dialog is displayed.

2. Enter the diagram name and type and click New. 

The MSC is saved as a separate entity that is not automatically ap-
pended to the Organizer structure. You may want to add the MSC 
to the Organizer in order to provide an instant access to it from the 
Organizer. See “Starting on a New MSC Icon” on page 1731.

Creating an MSC from the Organizer

The procedure is identical to starting the MSC Editor with no existing 
MSC icon. See “Starting on an Existing MSC” on page 1728.

Renaming an MSC
You can change the name of an MSC. The name of an MSC is reflected 
in the MSC heading.

To change the name, simply edit the heading.
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Opening an MSC
You can open an MSC from the MSC Editor or from the Organizer.

Opening an MSC File from the MSC Editor
1. Select Open from the File menu. A File Selection Dialog is issued.

2. Select a file and click OK.

You can open binary GR files (*.msc) or textual PR files (*.mpr).

Opening an MSC from the Organizer
1. Select an MSC in the Organizer.

– Alternatively, if the MSC is associated with an SDL diagram, 
you can select the associated MSC link icon (looking like an 
MSC icon displayed in dashed form, see Figure 322 on page 
1729).

2. Double-click the MSC icon.

Saving an MSC
There are several ways to save an MSC. Either you can save changes 
made to one specific MSC or all MSCs modified during the current ses-
sion. 

Saving an MSC in the MSC Editor

• Select Save from the File menu or click the quick-button for Save.

If the diagram is newly created, a file selection dialog is issued 
where you can specify the file to save the diagram on.

Saving All MSCs

You can make a global save of all the MSCs that are open in the current 
session, and that are modified:

• Select Save All from the File menu. (You will be prompted to spec-
ify a file for new diagrams that have never been saved on file.)

Saving an MSC in MSC/PR Format

You can save an MSC in the MSC/PR format. See “Generate MSC PR” 
on page 1644 in chapter 40, Using Diagram Editors.
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Saving a Copy of an MSC
You can save the MSC you are working on into another file. You may 
either continue working with the original file or with the newly created 
copy.

Continuing Working with the New Copy

1. Select Save As from the File menu. A file selection dialog is issued. 

The default file name which is suggested is the same file as the orig-
inal was stored on, appended with an integer suffix (1, 2,..., N) in or-
der to build up a unique file name. 

2. Click OK. The MSC is copied to the specified file, the file contain-
ing the original is closed, and the window from where the save was 
made remains open for editing the newly created file.

Continuing Working with the Original

1. Select Save a Copy as from the File menu. A file selection dialog is 
issued. 

The default file name which is suggested is the same file as the orig-
inal was stored on, appended with an integer suffix (1, 2,...,N) that 
guarantees a unique file name.

2. Click OK. The MSC is saved on the specified file, and the window 
with the file from where the save was made remains open for edit-
ing.

Displaying an Opened MSC
You can display an MSC that is currently opened by the MSC Editor. 
(The MSC that you would like to see may reside in a window which is 
not on top of the screen.)

The Diagrams menu shows all MSCs (up to a maximum of the last nine 
to have been opened). If more than nine MSCs are open, a tenth menu 
choice, List All, provides access to a list dialog where all MSCs current-
ly opened are listed.
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Rearranging an MSC
The following topics are discussed:

• Resizing an MSC
• Changing the Spacing

Resizing an MSC

Resizing Automatically

When you append objects by double-clicking, the MSC Editor will au-
tomatically enlarge the MSC size when the MSC has grown so that it 
reaches the bottom or right of the drawing area. The drawing area is en-
larged according to the value of a preference parameter. 

Resizing Manually

1. Display the MSC you want to resize.

2. From the Edit menu, select Drawing Size. A dialog appears.

3. Type in the new width and height for the MSC within the allowed 
range.

4. Click OK. The MSC is resized accordingly.

Changing the Spacing
When the MSC Editor layouts an MSC, it makes use of a horizontal and 
vertical spacing parameter that affect the total height and width of the 
MSC. All instances and events on instances are positioned with an inte-
ger multiple of the spacing parameters.

1. From the View menu, select Insert Options (see “Insert Options” on 
page 1633 in chapter 40, Using Diagram Editors). A dialog ap-
pears.

2. Drag the sliders for a coarse adjustment. Click left or right on the 
slider bar for a fine adjustment.

– Smaller values will give the chart a compact appearance that 
may possibly make it more difficult to read. Text associated to 
July 2003 Telelogic Tau 4.5 User’s Manual ,um-st1 1735



Chapter 42 Editing MSC Diagrams 
symbols may overlap other symbols and text. Symbols may 
overlap each other.

– Larger values will give the chart a less cramped appearance and 
makes it easier to read to the price of a larger size. 

3. Click OK. 

Managing Windows
Each MSC Editor window shows one MSC, but you may open new win-
dows on a diagram and close windows that are no longer needed.

A newly opened window is a mirror image of the window from which 
the selection to open a window was made. Multiple windows may be 
opened and are all identical to the first. Any subsequent modifications 
made will reflect the same in either the original window, or any of the 
newly opened window(s). This option affords the possibility of viewing 
in more than one window, and can ideally be used in conjunction with 
the scaling factor when looking at a detailed MSC. 

Opening and Closing Windows
You open and close windows with the New Window and Close Window 
menu choices in the Windows menu. If you close the last opened win-
dow, the editor will exit.

Hiding and Showing Parts of the Window
The component parts of the MSC Editor window can be shown or hid-
den as required. On UNIX, if they are hidden, it increases the drawing 
area available to be used in the creation or modification of a diagram. 

To change the options for hiding and showing parts of the window, se-
lect Window Options from the View menu. These options can also be set 
as preferences, and some of them are available from quick-buttons:

• The quick buttons for text window on / off or symbol menu on / off.

• The quick button for instance ruler on / off.
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Selecting Objects
To select an object, you click it. The object will be marked with selec-
tion squares that indicates that it is selected. A filled selection square 
(not a grey) means that you can resize or move the object by dragging 
the square.

Related topics are:

• Selecting an Object That Has Associated Objects
• Extending, Reducing or Cancelling a Selection 
• Requesting Detailed Information on an Object.

Selecting an Object That Has Associated 
Objects
An object may have other objects associated to it. When you select an 
object, all of the object’s attributes are also selected:

• A symbol may have associated lines and text attributes.
• A line may have associated text attributes.
• A text object has no associated attributes.

Associated text, for example symbol text, symbol names and timer 
names, will be displayed in the text window.

When you open a condition or MSC reference symbol, the Connect di-
alog is also opened.

Extending, Reducing or Cancelling a Selection
The editor provides standard functions for extending, reducing and can-
celling selection of objects.

Requesting Detailed Information on an Object
The info window is an auxiliary window that provides additional infor-
mation about the object you have selected.

To open an info window:

1. Display the diagram on which you want additional information.

2. Select Info Window from the Window menu. The info window is 
displayed.
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Adding and Removing Objects
The topics discussed in this section are:

• Adding and Placing Symbols
• Adjusting Objects to the Grid
• Inserting Space for Events
• Inserting Space for Events Automatically
• Removing Space between Events
• Removing Objects
• Adding a Text Symbol
• Adding a Comment Symbol
• Adding an Instance Head Symbol
• Adding an Instance End Symbol
• Adding a Stop Symbol
• Adding a Condition, MSC Reference or Inline Expression Symbol
• Adding an Action Symbol
• Adding a Coregion Symbol
• Drawing a Message
• Drawing a Message-to-self
• Drawing a Timer
• Drawing a Process Create

Adding and Placing Symbols
1. You can add a symbol from the symbol menu to a chart in two ways:

– Automatically, by double-clicking the symbol in the symbol 
menu. The symbol will be placed at a location defined according 
to the type of symbol and in relation to the current selection. 
This will be further described for each symbol type.

– Manually, by first selecting it in the symbol menu and then 
clicking at the desired location in the drawing area. To cancel 
the operation before the symbol is added, press <Esc>.

2. Enter the symbol’s text attributes.

Adjusting Objects to the Grid
The MSC Editor positions symbols and lines automatically. When you 
draw and move symbols and lines, each object is positioned on the clos-
est intersection in the grid.
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Inserting Space for Events
When you work on an MSC, the space available between two events on 
an instance axis may not be sufficient for inserting new objects on the 
instance axis. The MSC Editor can reorganize the MSC in order to pro-
vide the required space.

1. Select the object before or after where to insert space. 

3. Turn the appropriate radio button on, depending on if you have se-
lected the object before or after where to insert space.

4. Type in the required number of events to insert (the default is 1 
event). A negative number implies removal of space.

5. Click OK. The MSC is rearranged and space is created on the in-
stance axis/axes.

Inserting Space for Events Automatically
Space is made on the instance axis when you select and add new sym-
bols from the symbol menu or when you move symbols in the diagram.

1. Select a symbol in the symbol menu and move the cursor to the 
place on the instance axis where you want to insert the symbol.

2. Click the mouse. The MSC is rearranged and space is created on the 
instance axis/axes.

Removing Space between Events
1. Select the object before where to remove space.

2. From the Edit menu, select Make Space. Alternatively click the 
quick-button for Make space for new events. The Make Space dia-
log is issued.

2. Click the quick-button for Remove space between events.
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Removing Objects
You can remove any selected object(s) this way:

1. Select the objects to remove.

2. Choose Clear from the Edit menu. The objects are removed.

Adding a Text Symbol
To add a text symbol automatically, double-click the text symbol in the 
symbol menu. The text symbol will be placed at the first available posi-
tion at the top of the drawing area, starting from the left of the diagram.

Adding a Comment Symbol
The following conditions apply to comment symbols in the MSC Edi-
tor:

• A comment symbol can only be connected to one symbol or event.
• Only one comment symbol may be connected to an object.
• A comment symbol cannot be connected to another comment sym-

bol or a text symbol.

Note:

Selecting an object to clear may implicitly select other objects. The 
Clear command will delete them all. See Figure 324.

Figure 324: Selecting an object that has associated objects

Clearing the instance Instance_1 will also remove the messages Message 1 and 
Message 2.

Selecting the instance head 
not only selects the instance 
head...

...but also, implicitly, the con-
nected messages
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To add a comment symbol automatically:

1. Select the object to which you wish to connect the comment.

2. Double-click the comment symbol in the symbol menu. The com-
ment symbol will be placed to the right of the selected object and be 
connected to it. (If no object was selected, the comment symbol will 
be placed at an empty position, and you will have to connect the 
symbol to an object manually, as described next.)

To add a comment symbol manually:

1. Select the comment symbol in the symbol menu and place it in the 
drawing area.

2. Click the handle on the comment symbol, and then click on the ob-
ject you wish to comment. A dashed line is drawn between the ob-
jects.

Adding an Instance Head Symbol
You can add a new instance either directly by using the instance head 
symbol, or you can visualize an instance that is started dynamically by 
using the process create line. The latter approach is described in “Draw-
ing a Process Create” on page 1751.

To add an instance head symbol automatically:

1. Select, if you wish, an object to use as reference point when posi-
tioning the instance head. 

2. Double-click the instance head symbol in the symbol menu.

– If an object was selected in the drawing area, the instance head 
symbol will be placed to the right of the selected object.

– If no object was selected, the instance head symbol will be 
placed on top of the MSC, at the first available location starting 
from the left. 

3. Fill in the instance head text fields. See Figure 325.
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Adding an Instance End Symbol 
The instance end symbol determines the end of the description of an in-
stance within an MSC. It does not describe the actual termination of the 
instance. That is done with the stop symbol, see “Adding a Stop Sym-
bol” on page 1743.

If you position the instance end symbol above (before) a symbol or line 
on the instance axis, all symbols and lines below (after) that object will 
be deleted. This is also true when you add a stop symbol:

. 

To add an instance end symbol automatically:

1. Select an object on the instance axis immediately above (before) the 
desired endpoint. 

2. Double-click the instance end symbol in the symbol menu.

Figure 325: The instance head text fields

Figure 326: Placing an Instance End

The placement of the instance end symbol deletes message Message2 but not 
Message1.

The instance kind

The instance name

The instance decomposition
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All symbols and lines on the instance axis below it are deleted. The 
instance axis line is truncated and connected to the instance end 
symbol.

Adding a Stop Symbol
The stop symbol at the end of an instance body indicates the termination 
of that instance, as opposed to the instance end symbol, which only de-
termines the end of the description of the instance within the MSC.

If you position the stop symbol above (“before”) a symbol or line on the 
instance axis, all symbols and lines below (“after”) that object will be 
deleted. See Figure 326 on page 1742.

To add a stop symbol automatically:

1. Select an object on the instance axis immediately above (before) the 
desired endpoint. 

2. Double-click the stop symbol in the symbol menu.

3. The instance axis line is truncated and is connected to the stop sym-
bol.

Drawing a Message
To draw a message you need to know from which instance it should be 
issued (the source instance) and to which instance it should be sent (the 
target instance). 

Drawing a Message Automatically

1. Select the object on the source instance axis immediately above (be-
fore) the place where you wish to draw the line.

2. Double-click the message symbol in the symbol menu. The MSC 
Editor inserts the base end of the message on the instance axis, with 
the target end of the message (the arrow) marked as unconnected 
(lost) and facing right. (Figure 327)
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3. Drag the target end to (or close to) the target instance axis and re-
lease the mouse button to connect the line. If you do not connect the 
end of the message, it will remain unconnected (lost), indicated by 
the filled circle.

4. Enter the message name and its parameters.

Drawing a Message Manually

1. Click the message symbol in the symbol menu.

2. To create a message or lost message:

Point at the source instance axis and click once (the circle indi-
cating a found message disappears when you are close enough 
to an instance axis). From now on, the base of the message is 
fixed to the source instance. The message is displayed as lost, 
following the mouse motion. (See Figure 327.)

Or

To create a found message:

Point between two instance axes and click once. The base of the 
message is fixed at this position.

3. Point at or close to the target instance axis, and click to connect the 
message end to the target instance. The line is connected pushing 
down subsequent symbols on the instance axis when necessary.

Figure 327: A lost message

Figure 328: A found message with a connected end
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If you do not connect the end of the message to an instance axis, it 
will remain unconnected (lost), indicated by the filled circle.

4. Enter the message name and message parameters. 

Inserting the Message Name and Message Parameters

1. The message name can be entered immediately.

2. Click the parameter selection rectangle (the lower one) so that it is 
the only selected object. Type the parameter list. The parenthesis 
around the parameter list are not displayed on the screen until you 
have entered a parameter.

Drawing a Message-to-self
Drawing a message-to-self is done similarly to drawing a message. (See 
“Drawing a Message” on page 1743.) The source instance is however 
always the same as the target instance.

Adding a Condition, MSC Reference or Inline 
Expression Symbol

Adding a Condition, MSC Reference or Inline Expression 
Symbol Automatically 

1. Select the object immediately above (before) the place on the 
instance axis where you wish to insert the symbol.

2. Double-click the condition, MSC reference or inline expression 
symbol in the symbol menu.

3. Type the condition or MSC reference name, or fill in the inline ex-
pression text.

 

Figure 329: The message text fields

and the message 
parameters here

Enter the message name 
here
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4. Connect the condition to the instances. See “Connecting the Condi-
tion or MSC Reference Symbol” on page 1746.

Adding a Condition, MSC Reference or Inline Expression 
Symbol Manually

1. Select the condition, MSC reference or inline expression symbol in 
the symbol menu.

2. Position the symbol at the desired point of the instance axis. The 
symbol is placed on the instance axis, pushing down subsequent 
symbols on the instance axis when necessary.

3. Type the condition or MSC reference name.

4. Connect the symbol to the instances. See “Connecting the Condition 
or MSC Reference Symbol” on page 1746.

Connecting the Condition or MSC Reference Symbol

In the MSC Editor you can connect the condition or MSC reference 
symbol to individual instances or perform a global connection.

When a symbol straddles an instance axis to which it is not connected, 
the axis line is drawn through the symbol. In Figure 330 the condition 
symbol with name Condition_name is connected to the instances a and 
c, but not to the instance b. 

To connect a condition or MSC reference to a number of instance axes:

1. Select the symbol to connect.

2. Select Connect from the Edit menu. The Connect dialog is opened:

Figure 330: A condition symbol

a b c

Condition_name
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3. Select the instances to be connected in the instance list. The instanc-
es that will be connected are highlighted.

– Click Connect to connect the condition or MSC reference sym-
bol to the instances you have selected.

– Click Global to connect the condition or MSC reference symbol 
globally to all instances in the list.

Drawing a Timer
Drawing a timer is done similarly to drawing a message line. The source 
instance is always the same as the target instance.

Drawing a Timer Automatically

1. Select the object on the instance axis immediately above (before) 
the place where you wish to draw the timer.

2. Double-click the timer symbol in the symbol menu. The MSC Edi-
tor inserts the timer. 

3. Drag the target end and release the mouse when you have reached 
the point where the timer should expire.

Figure 331: Connecting an instance
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4. If required, change the status of the timer by selecting Status from 
the Edit menu (see “Changing the Status of a Timer” on page 1749).

5. Enter the timer name and its parameters.

Drawing a Timer Manually

1. Click the timer symbol in the symbol menu.

2. Point at or close to the instance axis. Click once. The base of the 
timer is fixed and the timer is displayed as a vertical line, following 
the mouse motion.

3. Point at or close to the point on the axis where the timer should ex-
pire and click to connect the timer end. The timer end is connected 
and the timer is assigned the status timeout.

4. Enter the timer name and parameters. 

Drawing a Separate Timer Manually

1. Draw a timer.

2. Select one of the outermost selection squares (i.e. the selection 
squares not on the instance axis) and drag it so that the vertical ex-
tension of the timer disappears.

3. Enter the timer name and parameters. 

Changing Between Timer and Separate Timer

• Change a timer to a separate timer by selecting one of the outermost 
selection squares (i.e. the selection squares not on the instance axis) 
and dragging it so that the vertical extension of the timer disappears.

• Change a separate timer to a timer by selecting a selection square 
and dragging it vertically.

Inserting the Timer Name and Timer Parameters

1. The timer name can be entered immediately.

2. Click the parameter selection rectangle (the lower one) so that it is 
the only selected object. Type the timer parameters. The parenthesis 
around the timer parameters are not displayed on the screen until 
you have entered a parameter.
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Changing the Status of a Timer

Z.120 specifies two appearances for the timer symbol, depending on 
whether the timer has expired (i.e. timeout) or whether the timer is reset. 

• Timeout – A timer expires.
• Reset – A timer is stopped.
• Implicit reset – A timer is assigned a new value while active.To 

change the status of a timer:

1. Select the timer. 

2. From the Edit menu, select Status. The Timer status dialog is issued.

3. Click a radio button and then click OK. The status of the timer is 
changed accordingly.

Changing the Status of a Separate Timer

The status of a separate timer:

• Set – A timer is activated but has not yet expired.
• Timeout – A timer expires.

Figure 332: The timer text fields

Figure 333: Setting the timer status

Enter the timer name 
here

and the timer 
parameters here

A timer may 

...reset

or implicit reset.

be consumed...

(stopped)...
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• Reset – A timer is stopped.

To change the status of a timer:

1. Select the timer. 

2. From the Edit menu, select Status. The Timer status dialog is issued.

3. Click a radio button and then click OK. The status of the timer is 
changed accordingly.

Adding an Action Symbol
An action symbol corresponds to the SDL task symbol. You may 
choose to fill it with formal or informal expressions.

To add an action symbol automatically:

1. Select the object on the desired instance axis immediately above 
(before) the place where you wish to insert the symbol.

2. Double-click the action symbol in the symbol menu. The symbol is 
placed on the instance axis, pushing down subsequent symbols 
when necessary.

3. Fill in the action text.

Figure 334: Separate Timer status

A separate timer 

or reset (stopped)

...consumed...

may be set...
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Drawing a Process Create

Drawing a Process Create Automatically

1. Select the object on the source instance axis immediately above 
(before) the place where you wish to draw the process create.

2. Double-click the create process line in the symbol menu. The editor 
draws the create process line and places the instance head to the 
right of the source instance axis.

3. Enter the create parameters and the created instance head text fields 
(see Figure 325 on page 1742).

Drawing a Process Create Line Manually

1. Click the process create symbol in the symbol menu.

2. Click once on the source instance axis. The base of the process cre-
ate line is fixed to the source instance. The line is displayed as a 
dashed line. 

3. Click at the location where you wish to place the head of the created 
instance. The instance head and instance axis are automatically 
drawn.

4. Enter the create parameters and the created instance head text fields.

Adding a Coregion Symbol
The coregion allows you to specify unordered events on an instance. A 
coregion covers for instance the practically important case of two or 
more incoming messages where the ordering of consumption may be in-
terchanged.

1. Select the coregion symbol in the symbol menu.

2. Click once to designate the start point of the symbol at the instance 
axis.

3. Click a second time on the same instance axis to designate the end 
point.
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Collapsing and Decomposing Diagrams
You can create new high level and low level diagrams of your original 
diagrams. The topics discussed are:

• Collapsing a Diagram
• Decomposing a Diagram

Collapsing a Diagram
You can collapse the selected instance axes in a diagram to get an over-
view of the diagram.

1. Select two or more instance axes.

2. Select Collapse from the Edit menu.

Two diagrams are created from the original diagram. One display-
ing the collapsed instances and one displaying the collapsed dia-
gram.

See “Expand/Collapse” on page 1627 in chapter 40, Using Diagram Ed-
itors for more information.

Decomposing a Diagram 
You can create a new diagram of a segment of the original diagram. 

1. Select an instance axis.

2. Select Decompose from the Edit menu. A dialog is opened.

3. Enter or change the name of the decomposed instance and click OK. 

The instance in the original diagram will be marked as decomposed. 
A decomposed diagram is created and it is displayed in the Organiz-
er.

See “Decompose” on page 1631 in chapter 40, Using Diagram Editors 
for more information.
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Moving Objects
You can move one or several objects on the chart. Move several objects 
by first selecting them by framing or by using the shift buttons. The var-
ious procedures are described below:

• Moving a Text Symbol
• Moving a Comment Symbol
• Moving an Instance Head Symbol
• Moving an Instance End Symbol and a Stop Symbol
• Moving an Instance Axis
• Moving a Message
• Moving a Message-to-self
• Moving a Timer
• Moving a Process Create
• Moving a Condition or MSC Reference
• Moving an Inline Expression Symbol
• Moving an Action Symbol
• Moving a Coregion Symbol.

Moving a Text Symbol
You can move the text symbol freely across the drawing area.

• Drag the symbol to the new location. 

Moving a Comment Symbol
You can move the comment symbol freely across the drawing area. 

• Drag the symbol to the new location. The symbol and the line are 
redrawn accordingly. 

The orientation of the symbol may change and the connecting line 
is redrawn as required:
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Moving the comment symbol as shown in Figure 335 mirror flips the 
symbol in order to provide the shortest possible connection line.

If you move the object that the comment symbol is connected to, the 
comment symbol moves with it.

Moving an Instance Head Symbol
The instance head symbol can be moved horizontally or vertically. 

• Drag the instance head to the new location. 

– If you induce a horizontal movement, the entire instance axis 
and the connected objects are redrawn accordingly. 

– If you induce a vertical movement, only the instance head is 
moved. The objects on the instance axis are not affected.

Restrictions

The following restrictions apply when moving an instance head verti-
cally:

• You can move the instance head symbol upwards until it reaches the 
limit of the drawing area. See (1) in Figure 336 on page 1755. No 
other symbols or lines are affected by this operation.

– An instance head symbol that belongs to a process create line 
cannot, however, be moved above the head of its parent instance 
axis. 

• You can move the instance head symbol downwards until it reaches 
the instance end symbol or until it reaches the first event (condition, 
action, message, timer, stop or process create) that is connected to 

Figure 335: Moving the comment symbol.
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its instance axis. No other symbols or lines are affected by this op-
eration. See (2) in Figure 336 on page 1755

Moving an Instance End Symbol and a Stop 
Symbol
You can move the instance end symbol and stop symbol vertically but 
not horizontally. The instance end is moved horizontally when you 
move the instance head or the instance axis horizontally.

Figure 336: Moving the instance head and the instance end symbols

The bold arrows show the limitations applied on the leftmost instance head and in-
stance end.

(2)

(4)

(3)

(1)

The upper limit of 
the drawing area

The bottom of the 
drawing area 

The first event 
(symbol, mes-
sage, timer or pro-
cess create 

The last event on 
the instance axis
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You can move the symbol vertically:

• Down until it reaches the bottom of the drawing area. See (3) in 
Figure 336.

• Up until it reaches the last event (action, condition, message, timer 
or process create) that is connected to the instance axis (or reaches 
the instance head symbol). See (4) in Figure 336 on page 1755.

Moving an Instance Axis
You can move the instance axis line left or right by dragging it with the 
mouse. All connected messages and process create lines remain con-
nected as they were initially. The instance head and instance end or stop 
symbols will be moved accordingly. See (1) and (2) in Figure 337.

To move an instance axis:

• Drag the instance to the new location. The entire instance axis and 
the connected objects are redrawn accordingly. 

Figure 337: Moving lines

(1)(2)

(3)

(4)
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Moving a Message 
You can move a message vertically to any position within the limits set 
by the instance head symbol and the instance end or stop symbol of the 
source and target instances.

Moving the Entire Message

The base and the end of the message remain connected to the original 
source and target instances. The related message name and message pa-
rameters will be moved accordingly. See (3) and (4) in Figure 337.

You can also move the entire message to another pair of instance axes.

To move a message:

• Drag the message to the desired position. The message and its text 
attributes are redrawn accordingly.

Moving the Base or End of a Message

You can move the base or end of a message up or down along the axis 
that it is connected to by pointing to and dragging the appropriate (base 
or end) selection square to the new position. The opposite selection 
square will remain fixed.

The end (message input) cannot be moved above the base (message out-
put).

Moving a Message-to-self
You can move a message-to-self up or down along its instance axis or 
between instance axes by dragging it as you would move a message. See 
“Moving a Message” on page 1757.

Moving the Base or End of a Message-to-Self 

Use the same procedure as for a message to move the end (message in-
put) or base point (message output) of a message-to-self (see “Moving 
the Base or End of a Message” on page 1757). 
July 2003 Telelogic Tau 4.5 User’s Manual ,um-st1 1757



Chapter 42 Editing MSC Diagrams 
Moving a Condition or MSC Reference
You can move the condition and MSC reference symbol vertically 
along an instance axis to which it is connected; between the instance 
head and instance end, stop, or the bottom of the drawing area. To con-
nect or disconnect instances to the symbol, use the Connect dialog on 
the Edit menu.

To move the condition and MSC reference symbol:

• Drag the symbol to the new location on the instance axis. The sym-
bol is redrawn at its new location.

Moving an Inline Expression Symbol
You can move the inline expression symbol vertically along the instance 
axis.

• Click the left or right side of the inline expression and move it.

If the inline expression contains an involved axis, the inline expression 
cannot be moved below the instance end or stop symbol of that axis.

Moving a Timer 
You can move a timer up or down along its instance axis or between in-
stance axes by dragging it as you would move a message. The related 
timer name and parameters will be moved accordingly. See “Moving a 
Message” on page 1757.

Use the same procedure as for a message to move the end (the time-out 
or reset (stopped) arrow) or base point (the set symbol) of a timer (see 
“Moving the Base or End of a Message” on page 1757). 

Moving an Action Symbol
You can move the action symbol vertically along the instance axis be-
tween the instance head and instance end, stop or the bottom of the 
drawing area or to another instance axis.

Moving a Process Create
To move a process create line along its source instance axis, either move 
the process create line or its associated instance head symbol upwards 
or downwards. See “Moving an Instance Head Symbol” on page 1754.
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Moving a Coregion Symbol
You can move a coregion up or down along its instance axis by drag-
ging it as you would move a message. See “Moving a Message” on page 
1757.

If you point close to the start or end point of the coregion and start drag-
ging the mouse, the coregion will be resized accordingly.

Reconnecting Objects
Some of the objects that are managed by the MSC Editor can be recon-
nected:

• Reconnecting a Comment Symbol
• Reconnecting a Condition or MSC Reference Symbol
• Reconnecting a Message
• Reconnecting a Message-to-self
• Redirecting a Message.
• Reconnecting a Process Create

Reconnecting a Comment Symbol
A comment symbol can be reconnected to a different object or discon-
nected completely from all objects. 

1. Drag the comment symbol connection handle towards the new con-
nection point. The existing connection line is erased and a new line 
that follows the position of the mouse pointer is drawn.

2. Click the connection point on the new object. The connection line is 
fixed to the new object.

Disconnecting the Comment Symbol

• Select the dashed line to the comment symbol and delete it.
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Reconnecting a Message 
You can reconnect the base or the end of a message to another instance 
axis:

1. Drag the base or end of the message towards the desired instance ax-
is. As soon as you move the mouse the message is unconnected. 

2. When the mouse pointer is close to the new instance axis, release the 
mouse button. The message is now reconnected.

Reconnecting a Message-to-self 
You can reconnect the base or end of a message-to-self to another in-
stance axis. This changes the message-to-self to an ordinary message.

• Drag the end (or the base) of the message-to-self away from the in-
stance axis. As soon as you move the mouse, the line is displayed as 
an ordinary message line. Continue dragging the end of the line up 
or down to the new connection point and release the mouse button.

Redirecting a Message
When you draw a message, the message goes from the source instance 
to the target instance. It is possible to redirect a message (i.e. change its 
direction):

1. Select the message to redirect. 

2. Select the Redirect command on the Edit menu. The message is re-
drawn in the opposite direction, and the text attributes are posi-
tioned accordingly.

Messages-to-self and overtaken messages cannot be redirected.

In Figure 338 two messages are shown. The message sent first is con-
sumed after the message sent last, i.e. it is overtaken.

Figure 338: An overtaken message

Overtaken_msg

normal_msg
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Reconnecting a Condition or MSC Reference 
Symbol
To connect or disconnect instances to the symbol:

• Use the Connect dialog on the Edit menu, see “Connect” on page 
1630 in chapter 40, Using Diagram Editors. (Remember, at least 
one instance must be left connected.) 

Reconnecting a Process Create 
You can reconnect the base of a process create from one instance axis 
to another in a similar way as when reconnecting a message (see “Re-
connecting a Message” on page 1760).

Resizing Objects
All objects that are managed by the MSC Editor are automatically re-
sized according to the size of the text. However, you can manually re-
size a text or comment symbol.

Resizing a Text or Comment Symbol
There are two methods of resizing the text and the comment symbol:

• Select the Expand/Collapse command on the Edit menu to toggle 
between maximum and minimum size.

• Double-click the symbol, which causes the symbol to toggle be-
tween its minimal and maximal size.
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Printing Objects
It is possible to print only selected parts of an MSC.

1. Select the objects to be printed.

2. Select Print from the File menu.

3. Click the Setup button. 

4. Select the option Print only selected symbols.

5. Adjust, if necessary other Print options and click the OK and Print 
buttons. 

See also “Printing from the MSC Editor” on page 304 in chapter 5, 
Printing Documents and Diagrams. 

Figure 339: Printing only selected objects

Turn the Print only selected symbols button on
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