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Chapter
47 The SDL Index Viewer
The Index Viewer shows all definitions of SDL entities in a system 
and where they are used. The Index Viewer uses cross reference 
files produced by the Analyzer.

In previous versions of Telelogic Tau, the Message Sequence Chart 
Editor could also produce listings of definitions and references 
from an MSC. These older listings are also supported by the Index 
Viewer.

This chapter contains a reference manual to the Index Viewer; the 
functionality it provides, its menus, windows and symbols.
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Entities and Windows

Definitions and Uses

SDL 

The SDL Analyzer has the ability to generate files containing SDL cross 
references. See the Analyzer command described in “Set-Xref” on page 
2426 in chapter 55, The SDL Analyzer, and the Organizer’s Analyzer 
option described in “Generate a cross reference file” on page 115 in 
chapter 2, The Organizer. These files use a textual format that is human 
readable; the purpose of the Index Viewer is to provide a means to take 
advantage of this information in the graphical environment. SDL icons 
are used when displaying the contents of the files in a graphical way.

MSC

In previous versions of Telelogic Tau, the Message Sequence Chart Ed-
itor featured the generation of MSC cross references. These entities had 
properties that were similar to SDL cross references. Where possible, a 
direct mapping from MSC to the corresponding SDL concept were 
made. A few concepts were added so that all information of interest 
could be extracted from an MSC. 

MSC icons identify the various MSC entities graphically, and are sup-
ported for backward compatibility reasons.

SDL Icons
Each type of SDL entity has a unique name and icon used in the Index 
Viewer. The different SDL diagram types use the same icon and type 
name as in the Organizer’s Main window. For other types of entities, the 
following icons and names are used:

Icon Name

OPERATOR

PACKAGE_INTERFACE

CHANNEL
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SIGNALROUTE

GATE

INPUT

OUTPUT

CONNECTION

CREATE

TASK

SIGNAL

SIGNALLIST

GENERATOR

FPAR; PROCESS_PARAM, 
PROCEDURE_PARAM (actual param.)

STATE

NEXTSTATE

TIMER

LABEL (in-connector, out-connector)

INSTANTIATION

SET

USE

INHERITS

JOIN

STATE_LIST

ATLEAST

DECISION

Icon Name
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SAVE

DCL; VARIABLE

NEWTYPE; SYNTYPE; SORT

SYNONYM

RESET

IMPORT; IMPORT_DEF (i.e. Imported)

LITERAL

VIEW; VIEW_DEF (i.e. Viewed)

REMOTE_PROCEDURE

REMOTE_VARIABLE

SIGNALSET

ACTIVE

TRANS_OPTION (i.e. transition option)

EXPORT

ENAB_COND (i.e. enabling condition)

CONT_SIGNAL (i.e. continuous signal)

NUMBER_INST (i.e. number of instances)

EXPORTED_PROCEDURE

(PROCEDURE) CALL

REFERENCE

FIELD

Unknown symbol type. Used for diagrams when 
the type of the diagram for some reason could not 
be determined.

Icon Name
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MSC Icons
Each type of MSC entity has a unique name and icon used in the Index 
Viewer. The MSC diagram uses the same icon as in the Organizer’s 
Main window. For other types of entities, the following icons and 
names are used:

Icon Name

CONDITION

CREATE of instance

INPUT of message

INSTANCE head

OUTPUT of message

RESET of timer

SET of timer

STOP of process

TIMEOUT (expire of timer)

Unknown symbol type. Used for diagrams when 
the type of the diagram for some reason could not 
be determined.
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Index Viewer Window
All entities defined in the system are listed in alphabetical order in the 
Index Viewer window. The entities are sorted alphabetically according 
to either name, or type and name. For each entity, there may be a list of 
uses of the entity. The general characteristics of the window is described 
in chapter 1, User Interface and Basic Operations.

The Drawing Area
The window contains a list of all definitions of entities in the current 
SDL system or the current MSC diagram. The first line in the list gives 
the name of the current cross reference file. 

For each entity, the following information is presented: 

• An icon identifying the type of entity (see “SDL Icons” on page 
2018 and “MSC Icons” on page 2021)

• The name and type of the entity.

• A reference to the diagram the entity definition is located in.

• The number of definitions with an asterisk in front, if more than one 
definition of the entity exists (in SDL diagrams, it is only states that 
can have multiple places of definition for one entity).

• The number of cross references found (only for SDL entities; not 
applicable to MSC entities)
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To double click on a defined entity in the window is the same operation 
as Show Definition in the Tools menu (see “Show Definition” on page 
2029). If there are several definitions associated with the entity, one of 
them is selected. If you double click again, another definition is select-
ed. The list of definitions associated with the entity is traversed in a cir-
cular pattern.

To double click on a use in the window is the same operation as Show 
Use in the Tools menu (see “Show Use” on page 2030). If there are sev-
eral uses associated with the symbol, one of them is selected. If you 
double click again, another use is selected. The list of uses associated 
with the reference symbol is traversed in a circular pattern.

Fast Search
There is a fast search operation available when the Index Viewer draw-
ing area has the input focus. Just start typing on the keyboard, and the 
list of entities will be searched from the top. The first matching entity 
will be selected.

Figure 437: The Index Viewer window
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Note that the fast search operation will only match if what you type 
matches the beginning of the text for an entity. For instance: If you type 
“Ga”, you will find the entity Game_On if the entities are sorted with 
name first, while you will not find it if you type “On”. The normal 
Search operation does not have this restriction.

The search string used by the fast search operation will be reset when-
ever any other operation than the fast search operation is performed. For 
instance, if you have typed “Ga” and the index viewer has found the en-
tity Game_On, and you select another entity and start typing again, then 
the search string used for the search operation will not contain the initial 
“Ga” characters (and the fast search operation will start searching from 
the top of the list).

It is possible to use the delete character to correct any spelling mistakes. 
You can see what you have typed in the message area. Matched charac-
ters are shown in non-capital letters, while unmatched are shown in cap-
ital letters.

The Menu Bar

File Menu

The File menu contains the following menu choices:

• Open
(See “Open” on page 9 in chapter 1, User Interface and Basic Op-
erations.)

• Print
(See “Printing from the SDL Suite” on page 307 in chapter 5, Print-
ing Documents and Diagrams.)

• Exit
(See “Exit” on page 15 in chapter 1, User Interface and Basic Op-
erations.)

View Menu

The View menu contains the following menu choices:

• Window Options
• Index Options
• Filter Types
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 Index Viewer Window
• Filter Uses
• Filter Diagrams
• Set Scale

Window Options

Sets options for which parts of the Main window to show. The dialog 
controls whether to show the tool bar and the status bar.

Index Options

Determines the appearance of each entity in the window.

The following alternatives are available:

• Compact:

• Vertical Compact:

• Horizontal Detailed:

• Detailed:

Figure 438: The Index Options dialog
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Filter Types

Determines which entity types to show/hide in the entity list. A dialog 
is opened with a sorted list of all entity types found in the current cross 
reference file:

• Show

Shows entities in the Index Viewer window that have a type that is 
selected in the dialog. Entities with other types are hidden.

• Hide

Hides entities in the Index Viewer window that have a type that is 
selected in the dialog. Entities with other types are shown.

• Show All

Shows entities of all types in the Index Viewer window.

An SDT preference, FilterTypes can be set to an initial list of entities to 
show or hide whenever the Index Viewer is opened. Another SDT pref-
erence, ShowSelectedTypes, determines if the mentioned types should 

Figure 439: The Filter Types dialog

The figure shows some entity types for an SDL system. See “MSC Icons” on page 
2021 for a list of MSC entities.
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 Index Viewer Window
be shown or hidden. See “FilterTypes” on page 276 in chapter 3, The 
Preference Manager.

Filter Uses

Determines which uses to show/hide. The dialog works in the same way 
as the dialog for Filter Types. The associated SDT preferences are 
named FilterUses and ShowSelectedUses.

Filter Diagrams

Hide/show entities based on which diagram they are defined in. The di-
alog works in the same way as the dialog for Filter Types. The most 
common use of this operation is to hide definitions from the SDL pre-
defined package. The associated SDT preferences are named FilterDi-
agrams and ShowSelectedDiagrams.

Figure 440: The Filter Uses dialog
July 2003 Telelogic Tau 4.5 User’s Manual ,um-st1 2027



Chapter 47 The SDL Index Viewer 
Set Scale

Issues a dialog where the scale for the Tree window may be set.

Tools Menu

The Tools menu contains the following menu choices:

• Show Organizer
(See “Show Organizer” on page 15 in chapter 1, User Interface and 
Basic Operations.)

• Search
• Search Again
• Show Definition
• Show Use

Search

Searches for a visible text in the entity list shown in the Main window.

Figure 441: The Filter Diagrams dialog
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• Search for

Specifies the text string to search for. As a special case, a GR Ref-
erence obtained from for instance an editor may also be specified.

• Ignore Case, Consider Case 

These options toggles between a case insensitive and a case sensi-
tive search. 

• Search

Starts the search and closes the dialog. The first symbol containing 
the text is selected. The search starts from the selected symbol, if 
any, or from the first symbol in the first tree.

If the search reaches the end of the trees, you are asked whether to con-
tinue the search from the first tree.

If the text cannot be found among the visible information, you are in-
formed in a confirmation dialog.

Search Again

Searches again for the same text as in the latest search. The behavior is 
the same as described in “Search” on page 2028.

Show Definition

Opens an editor containing the specified definition of the entity selected 
in the entity list. The diagram symbol containing the definition becomes 
selected in the editor.

Figure 442: The Search dialog
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The name and behavior of this menu choice depends on the number of 
existing definitions for the selected entity:

• If only one definition exists, that definition is shown in the editor.

• If more than one definition exists, a separate menu choice is avail-
able for the first 9 definitions: Show Definition 1, Show Definition 
2, etc. The specified definition is shown in the editor.

• If more than 9 definitions exist, an additional menu choice Show 
Definition... is available. This menu choice opens a dialog in which 
the number of the definition can be specified.

Show Use

Opens an editor, showing the selected use of an entity. The Show Use 
operation works in the same way as the Show Definition operation.

Popup Menus
The following tables lists the menu choices in the window’s popup 
menus and a reference to the corresponding menu choice in the menu 
bar.

On the Window Background

On an Entity in the Window

Search “Search” on page 2028.

Search Again “Search Again” on page 2029.

Search “Search” on page 2028.

Search Again “Search Again” on page 2029.

Show Definition “Show Definition” on page 2029. The same 
menu choice variations apply.
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Keyboard Accelerators
Apart from the general keyboard accelerators, the following accelerator 
can be used in the main window:

Quick Buttons
The following quick button is special to the Index Viewer window. The 
general quick buttons are described in “General Quick-Buttons” on 
page 24 in chapter 1, User Interface and Basic Operations.

Accelerator Reference to corresponding command

Ctrl+E “Show Definition” on page 2029

Toggle Order
Switches the entity sort order between name and type and name.
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