
July 2003 Telelo

Chapter
48 The SDL Coverage 

Viewer
The Coverage Viewer shows the coverage of a simulation or valida-
tion in the terms of executed transitions or symbols in the system. 
The information used by the Coverage Viewer can be stored in a 
coverage file with the file extension .cov.

Coverage files can be generated by the SDL Simulator and the SDL 
Validator.

This chapter contains a reference manual to the Coverage Viewer; 
the functionality it provides, its menus, windows and symbols.
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Chapter 48 The SDL Coverage Viewer 
Coverage Viewer Windows
The Coverage Viewer has two windows, the Main window and the Cov-
erage Details window. The Main window graphically shows the simu-
lation or validation coverage of transitions or symbols in a tree corre-
sponding to the system structure. The Coverage Details window shows 
a more detailed coverage chart for a node in the tree.

The Main window is opened when the Coverage Viewer is started, 
whereas the Coverage Details window is not opened initially. The gen-
eral characteristics of these windows are described in chapter 1, User 
Interface and Basic Operations.

The Main Window
The Main window shows a graphical tree representing the diagram 
structure of the simulated or validated system. The tree can either 
present Transition Coverage or Symbol Coverage; the mode is con-
trolled by a user option. When the Coverage Viewer first opens a cov-
erage file, the preference ShowTransitions is used to determine the de-
fault mode.

At the top of the drawing area, above the root of the tree, is a text iden-
tifying the type of coverage tree (transition/coverage) and the name of 
the current coverage file.

In the tree, the different SDL diagram types use the same icons as in the 
Organizer’s main window. For an explanation of all other icons, see 
“SDL Icons” on page 2018 in chapter 47, The SDL Index Viewer.
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The Main Window
Transition Coverage
When the tree shows transition coverage, the lowest level in the tree 
consists of transitions, represented by a small SDL input symbol. Both 
states and transitions are visible below the process and procedure dia-
grams in the tree structure. The start transitions are treated as all other 
transitions, even though they are represented in the tree by an SDL start 
symbol.

Figure 443: Transition coverage in the Main window
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Chapter 48 The SDL Coverage Viewer 
Symbol Coverage
When the tree shows symbol coverage, the lowest level in the tree con-
sists of symbols corresponding to SDL symbols found in flow diagrams.

Figure 444: Symbol coverage in the Main window
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The Main Window
Nodes
Each node in the tree consists of three parts:

• A graphical symbol indicating the type of node, either:

– In SDL systems containing packages, an extra root node named 
“(total)” is introduced, showing the grand total for the system 
and all packages

– An SDL diagram (for instance, Figure 445 shows a process type 
symbol)

– An SDL state

– A transition (start transition or input of signal/timer)

– Any symbol that can be found in SDL flow diagrams

The graphical notation uses the same symbols as in SDL, where ap-
plicable. See also “SDL Icons” on page 2018 in chapter 47, The SDL 
Index Viewer.

• The name of the node is presented as text below the symbol (in 
Figure 445, the name of the process type is “Door”). An exception 
to this is the symbols at the lowest level in a symbol coverage tree. 
These symbols are shown without a name. 

• The number of executed transitions/symbols associated with the 
node is presented below the name. For symbols above the lowest 
level of the tree, a range is also shown indicating the number of 
times the least and most executed transition/symbol below the node 

Figure 445: A coverage node
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Chapter 48 The SDL Coverage Viewer 
has been executed. The process type symbol in Figure 445 reads 
“2 (0 - 1)” which means that:

– Two transitions/symbols have been executed.

– The least frequently executed transition / symbol in process type 
Door has been executed zero times.

– The most frequently executed transition / symbol in process 
type Door has been executed once.

Line Thickness

The number of executed transitions/symbols shown below the node 
symbol also controls the thickness of the vertical line connecting the 
node with its parent node. 

The line thickness thus gives a visual clue about how much the different 
branches of the tree have been executed, expressed as a relative number. 
The thicker the line, the more the tree branch has been executed.

Filling Level

In each node symbol, the number of transitions/symbols that have been 
executed at least once in relation to the total number of transitions/sym-
bols in that node is also displayed. This is done by filling the node sym-
bol with a gray pattern, showing the percentage level (number of exe-
cuted divided by total number).

The higher the filling level, the more transitions/symbols have been ex-
ecuted. Figure 445 for instance shows that 50% of the total number of 
transitions/symbols have been executed.

Dashed Nodes

The visibility condition determines if nodes should be shown or not. A 
node that should not be shown according to the visibility condition can 
be visible anyway because a child node is shown. To indicate that a vis-
ible node does not match the visibility condition, the node is drawn with 
a dashed line. 
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The Main Window
The Visibility Condition
When the Coverage Viewer first opens a coverage file, every node in 
the coverage tree is shown. You can hide and show nodes in two ways, 
either via the expand/collapse mechanism (see “View Menu” on page 
2042), or via the visibility condition.

By using the visibility condition, you can control which nodes should 
be visible or not. Only those nodes that meet the visibility condition are 
shown in the tree, and you cannot use the expand mechanism to see 
nodes that do not meet the visibility condition. 

The visibility condition is a threshold value for the number of times a 
transition/symbol is executed. It is specified with the Set Visibility menu 
choice in the Tree menu (see “Set Visibility” on page 2044). It can also 
be changed by quick buttons, as well as the Increase Tree and Decrease 
Tree menu choices in the Tree menu.

A node in a fully expanded tree is visible either if:

• The number of executed transitions/symbols associated with the 
node meets the visibility condition.

• At least one of the underlying nodes is visible.

The symbol of a node that meets the second condition but not the first 
one becomes dashed to indicate that the node itself does not meet the 
visibility condition.

Single and Double Clicks
When you select a node in the main window, the Coverage Details win-
dow is updated and displays the coverage chart for the selected node. 
The Coverage Details window must be opened by the Show Details 
menu choice in the Tools menu.

To double-click on a symbol in the main window opens an SDL Editor 
with a diagram that corresponds to the selected symbol. See “Show in 
Editor” on page 2047 for more information.
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Chapter 48 The SDL Coverage Viewer 
Quick Buttons
The following quick buttons are special to the Main window. The gen-
eral quick buttons are described in “General Quick-Buttons” on page 24 
in chapter 1, User Interface and Basic Operations.

Coverage Type
Switches between a transition coverage tree and a symbol coverage tree 
in the Main window.

Show Bottom
Changes the appearance of the coverage tree to show only those transi-
tions/symbols that have been executed the least number of times, i.e. 
having a number of executions exactly equal to the lowest number of 
available executions. This command changes the visibility condition.

Show Top
Changes the appearance of the coverage tree to show only those transi-
tions/symbols that have been executed the most number of times, i.e. 
having a number of executions exactly equal to the highest number of 
available executions. This command changes the visibility condition.

Show Whole Tree
Changes the appearance of the coverage tree to show all transi-
tions/symbols. The visibility condition is reset to zero or more (>=0).

Show Details Window
Pops up (opens/raises) the Coverage Details window.
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The Main Window
The Menu Bar

File Menu

The File menu contains the following menu choices:

• Open
(See “Open” on page 9 in chapter 1, User Interface and Basic Op-
erations.)

• Open Directory

• Merge

• Save
(See “Save” on page 11 in chapter 1, User Interface and Basic Op-
erations.)

• Print
(See “Printing from the SDL Suite” on page 307 in chapter 5, Print-
ing Documents and Diagrams.)

• Exit
(See “Exit” on page 15 in chapter 1, User Interface and Basic Op-
erations.)

Open Directory

This menu choice is used to merge information from all coverage files 
(*.cov) in one directory. 

A directory selection dialog is opened. The first coverage file in the 
specified directory is opened, and all other coverage files in the speci-
fied directory are merged. The resulting coverage information is pre-
sented in the main coverage window.

Note:

It is only possible to merge coverage files created from the same 
SDL system, i.e. the Open Directory operation will fail if there are 
coverage files from different SDL systems in the same directory.
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Chapter 48 The SDL Coverage Viewer 
Merge

Reads an additional coverage file about the same system and merges the 
coverage information in it with the current coverage information. A File 
Selection Dialog is opened with the file filter set to *.cov. The contents 
of the main window is augmented by the additional information read 
from the selected file.

It is not possible to merge coverage files with another system.

View Menu

The View menu contains the following menu choices:

• Expand
• Expand Substructure
• Expand All
• Collapse
• Window Options
• Set Scale

Expand

Expands the selected node one level down.

Expand Substructure

Expands the selected node as much as possible.

Expand All

Expands all nodes as much as possible.

Collapse

Collapses the selected node, i.e. hides all child objects. This menu 
choice is named Collapse All if no node is selected. Invoking the Col-
lapse All menu choice collapses the top node.

Window Options

Sets options for which parts of the Main window to show. The dialog 
controls whether to show the tool bar and the status bar.

Set Scale

Issues a dialog where the scale for the main window may be set.
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The Main Window
Tree Menu

The Tree menu contains the following menu choices:

• Tree Options
• Symbol Options
• Line Options
• Increase Tree
• Decrease Tree
• Set Visibility

Tree Options

Sets options for which type of coverage tree to show in the main win-
dow. The dialog controls whether to show either:

– Transition Coverage 
– Symbol Coverage

Symbol Options

Sets options for how to show execution numbers for the nodes in the 
coverage tree. The dialog controls whether to show the numbers for 

– Every node,
– the Bottom nodes only, or
– Do not show numbers at all.

Line Options

Sets options for controlling the line thickness of the nodes in the cover-
age tree.

Figure 446: The Line Options dialog
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Chapter 48 The SDL Coverage Viewer 
• Normal line thickness

• Logarithmic line thickness

The dialog controls whether to show Normal line thickness or Log-
arithmic line thickness, i.e. the thickness is proportional either to the 
executed number of transitions/symbols, or to the logarithm of the 
same number. 

• Max line thickness

With a slide bar, you may also specify the Max line thickness, mea-
sured in 1/10 mm. The possible range of values is 1–200. The de-
fault is 60, which is the thickness of the line connecting the top node 
of the tree.

Increase Tree

Shows more of the coverage tree by calculating a visibility threshold 
(see “The Visibility Condition” on page 2039) that makes at least one 
more symbol become visible. 

Decrease Tree

Shows less of the coverage tree by calculating a visibility threshold (see 
“The Visibility Condition” on page 2039) that makes at least one more 
symbol become hidden.

Set Visibility

Sets options to control the visibility condition of the coverage tree (see 
“The Visibility Condition” on page 2039).

Figure 447: The Set Visibility dialog
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The Main Window
The dialog controls:

• Threshold

The value which may be set with the slide bar, 

• Show symbols executed >= threshold

• Show symbols executed <= threshold

The option whether to make nodes visible that are executed more 
than or less than the threshold value. 

Tools Menu

The Tools menu contains the following menu choices:

• Show Organizer
(See “Show Organizer” on page 15 in chapter 1, User Interface and 
Basic Operations.)

• Search
• Search Again
• Show Coverage
• Show in Editor
• Show Details

Search

Searches for a visible node name in the coverage tree shown in the Main 
window.

Figure 448: The Search dialog
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Chapter 48 The SDL Coverage Viewer 
• Search for

Specifies the text string to search for. As a special case, a GR Ref-
erence obtained from for instance an editor may also be specified.

• Ignore Case, Consider Case 

These options toggles between a case insensitive and a case sensi-
tive search. 

• Search

Starts the search and closes the dialog. The first symbol containing 
the text is selected. The search starts from the selected symbol, if 
any, or from the first symbol in the tree.

If the search reaches the end of the tree, you are asked whether to con-
tinue the search from the first node.

If the text cannot be found among the visible information, you are in-
formed in a confirmation dialog.

Search Again

Searches again for the same text as in the latest search. The behavior is 
the same as described in “Search” on page 2045 above.

Show Coverage

Opens an SDL Editor for all the transitions/symbols that meet a certain 
threshold condition in the tree below the selected symbol. The diagram 
symbols corresponding to the transitions/symbols become selected in 
the SDL Editor.

Figure 449: The Show Coverage dialog
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The Main Window
The dialog controls the Editor threshold value with a slide bar, as well 
as whether to show transitions/symbols that are executed, either:

• less than 
• equal to 
• more than 

the threshold value. 

The Show button displays all diagram pages containing transitions or 
symbols that meet the threshold condition, one page at a time, with a 
confirmation dialog between each page.

Transitions (represented by the input symbol) or symbols matching the 
threshold condition are selected and colored with a temporary back-
ground color. The temporary background color can be removed with 
SDL editor > View > Temporary Colors > Remove. The temporary 
background color is also removed when the diagram is unloaded from 
the editor.

There is a No Dialog button in the confirmation dialog that can be used 
to avoid displaying the confirmation dialog for each page with symbols 
to show.

Show in Editor

Opens an SDL Editor with a diagram that corresponds to the selected 
symbol. If the selected symbol is located in a process or procedure dia-
gram, the corresponding diagram symbol becomes selected in the dia-
gram. Only applicable on transition/symbol icons at the lowest level in 
the tree, including start states.

Show Details

Opens or raises the Coverage Details window, showing a coverage chart 
for the selected node.

Note:

The editor threshold condition specified in this dialog does not af-
fect the visibility condition. It only controls which transitions/sym-
bols to show in an SDL Editor.
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Popup Menus
The following tables lists the menu choices in the main window popup 
menus and a reference to the corresponding menu choice in the menu 
bar, or the corresponding quick button.

On the Main Window Background

On a Node in the Coverage Tree

Keyboard Accelerators
Apart from the general keyboard accelerators, the following accelerator 
can be used in the main window:

Show Bottom “Show Bottom” on page 2040.

Show Top “Show Top” on page 2040.

Show Whole Tree “Show Whole Tree” on page 2040.

Show Details “Show Details” on page 2047.

Expand All “Expand All” on page 2042.

Collapse All Collapses the whole tree, i.e. only the top 
node becomes visible.

Show in Editor “Show in Editor” on page 2047. 

Expand “Expand” on page 2042.

Expand Substructure “Expand Substructure” on page 2042.

Collapse “Collapse” on page 2042.

Accelerator Reference to corresponding command

Ctrl+E “Show in Editor” on page 2047
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 Coverage Details Window
Coverage Details Window
The Coverage Details window presents more detailed coverage infor-
mation for the node selected in the Main window. It contains a coverage 
chart for transitions or symbols, depending on what type of tree is 
shown in the main window. Above the chart is a text identifying:

• The type of coverage chart
• The type and name of the node
• The total number of executed transitions/symbols.
• The number of covered transitions/symbols.
• The number of not covered transitions/symbols.

The Coverage Details window is updated when the selection in the 
Main window is changed. The Coverage Details window is updated to 
show the coverage chart for the node selected in the Main window.

Figure 450: Coverage Details window
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The Coverage Chart
The coverage chart shows how many transitions/symbols in the node 
that have been executed a certain number of times:

• The horizontal axis denotes the number of times a transition/symbol 
is executed; the range of the axis is the same as the range shown for 
the node in the Main window.

• The vertical axis denotes the number of transitions/symbols that has 
been executed a specific number of times; the range of the axis can-
not generally be determined from the values shown for the node in 
the Main window.

For each value along the horizontal axis (no of times), a vertical bar 
shows how many transitions/symbols have been executed that specific 
number of times. The vertical axis scale is adjusted to include the high-
est vertical bar, but this can be changed by using the Chart Options 
menu choice in the View menu (see “Chart Options” on page 2052), or 
the quick buttons.

The left most bar is automatically selected when a new coverage chart 
is displayed. The selection can be moved by using the left and right ar-
row keys. Double clicking on a bar in the chart executes the Show in Ed-
itor command, see “Show in Editor” on page 2052.

Just below the horizontal axis is the visibility line. It underlines the bars 
that correspond to the visible nodes in the coverage tree in the Main 
window. “Visible” in this case means visible according to the visibility 
condition. Nodes that are hidden by collapsing a parent node are still re-
garded as visible in this context.
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 Coverage Details Window
Quick Buttons
The following quick buttons are special to the Coverage Details win-
dow. The general quick buttons are described in “General Quick-But-
tons” on page 24 in chapter 1, User Interface and Basic Operations.

The Menu Bar

File Menu

The File menu contains the following menu choices:

• Print
(See “Printing from the SDL Suite” on page 307 in chapter 5, Print-
ing Documents and Diagrams.)

• Close
(See “Close” on page 14 in chapter 1, User Interface and Basic Op-
erations.)

Show in Editor
Corresponds to the description in “Show in Editor” on page 2052.

Increase Vertical Scale
Increases the vertical scale of the coverage chart by decreasing the value 
of the upper range of the vertical axis. Those bars that “overflows” the 
range of the vertical axis are shown with an up arrow at the top of the 
bars to indicate that the bars in reality are higher.

Decrease Vertical Scale
Decreases the vertical scale of the coverage chart by increasing the 
value of the upper range of the vertical axis. The reverse of the Increase 
Vertical Scale quick button above.

Show Coverage Tree
Pops up the Coverage Viewer’s main window (the Coverage Tree win-
dow).
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View Menu

The View menu contains the following menu choices:

• Window Options
• Chart Options
• Set Scale

Window Options

Sets options for which parts of the Coverage Details window to show. 
The dialog controls whether to show the tool bar and the status bar.

Chart Options

Sets options controlling the appearance of the coverage chart. 

The dialog controls the value of the upper limit of the vertical axis in the 
chart and whether to:

• Show visibility line

• Hide Visibility line

Set Scale

Issues a dialog where the scale for the Coverage Details window may 
be set.

Tools Menu

The Tools menu contains the following menu choices:

• Show in Editor
• Show Coverage Tree

Show in Editor

Opens an SDL Editor for all the transitions/symbols of the selected ver-
tical bar in the coverage chart. The diagram symbols corresponding to 
the transitions/symbols become selected in the SDL Editor. 

A confirmation dialog is displayed between each diagram page.

Show Coverage Tree

Raises the Coverage Viewer’s main window.
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 Coverage Details Window
Popup Menu
The following table lists the menu choices in the Coverage Details win-
dow popup menu and a reference to the corresponding menu choice in 
the menu bar.

Keyboard Accelerators
Apart from the general keyboard accelerators, the following accelera-
tors can be used in the Coverage Details window:

Show Coverage Tree “Show Coverage Tree” on page 2052.

Accelerator Reference to corresponding command

Ctrl+E “Show in Editor” on page 2052
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