
July 2003 Telelogic Tau

Chapter
4 Tutorial: TTCN Suite 

Basics (in Windows)
This tutorial is intended as an easy introduction to the TTCN suite 
for the newcomer. It is assumed that you have some basic knowl-
edge about Windows. In addition, to find the TTCN suite meaning-
ful to use, you have to understand TTCN.

Note: Windows version

This is the Windows version of the tutorial. The UNIX version 
can be found in chapter 5, Tutorial: TTCN Suite Basics (on 
UNIX).

Note:

This document is a TTCN Suite primer and is not intended to 
provide a tutorial on TTCN. The volume TTCN Suite Method-
ology Guidelines introduces some basic TTCN features present-
ed with the aid of a simple example.
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Purpose of This Tutorial
The purpose of this tutorial is to make you familiar with the basic func-
tions of the TTCN Suite. You will start by creating a test suite and you 
will learn various ways of editing tables.

It is assumed that you know how to use Windows but that you have no 
or little previous knowledge about the TTCN Suite. However, to under-
stand the full use of the TTCN suite, you must have knowledge of 
TTCN. TTCN Suite Methodology Guidelines introduces some essential 
TTCN features, presented with the aid of a simple example.

Starting the TTCN Suite
It is assumed that the TTCN Suite (or Telelogic Tau) has been installed 
correctly and that the installation directory is:
C:\Telelogic\SDL_TTCN_Suite4.5

To start Telelogic Tau:

• Select the Telelogic Tau icon from the Start menu.

– You can also double-click the executable file sdt.exe, which 
should be located in:
C:\Telelogic\SDL_TTCN_Suite4.5\bin\wini386.

After a few seconds, the Organizer is started. The Organizer is the main 
window from which you have access to the tools in the Telelogic Tau 
environment. 

A welcome window, where you may read the license agreement for 
Telelogic Tau, will also be displayed. The window disappears as soon 
as you click the Continue button or perform any action in the Organizer.
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 Starting the TTCN Suite
The Organizer consists of a main window and a log window. In the main 
window, five areas – known as chapters – are displayed by default:

• Analysis Model
• Used Files
• SDL System Structure
• TTCN Test Specifications
• Other Documents

You may freely use these chapters to hold a number of documents and 
chapters may also be renamed, deleted and created – the actual use is a 
matter of personal taste.

More information about customizing the chapters can be found in “Cus-
tomizing the Organizer Chapters” on page 51 in chapter 3, Tutorial: The 
Editors and the Analyzer, in the SDL Suite Getting Started.

Figure 9: The Organizer main window
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Creating a TTCN Test Suite Document

What You Will learn
• To set the source and target directory
• To create a TTCN test suite

Setting the Source and Target Directory
You will begin by setting the source and target directory in the Organiz-
er. The source directory is where your new documents will be saved by 
default. The target directory is where generated files are put. Both of 
these directories must already exist – you cannot create them in the Or-
ganizer.

The Set Directories dialog is opened, and you may change the 
source and target directories.

1. Double-click the source directory icon in the Organizer window.

– You may also select the source directory icon and then select 
Edit from the Edit menu in the Organizer or you may select Set 
Directories from the File menu.
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 Creating a TTCN Test Suite Document
2. Select the source directory by writing the path in the text field or by 
browsing in the dialog that is opened when you click the folder but-
ton. Make sure that you have write access to the directory.

3. In the same way, you can change the target directory.

4. Click OK in the Set Directories dialog.

Figure 10: The Set Directories dialog
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Creating a New Test Suite
When you have set the source and target directories, you should create 
a new TTCN document.

1. Select the chapter TTCN Test Specification in the Organizer.

2. Select Add New from the Edit menu in the Organizer.

The Add New dialog is opened. In the dialog you should set the doc-
ument type and name.

3. Select TTCN and Test Suite or Modular Test Suite in the New docu-
ment type list. 

4. Type Tutorial in the New document name field.

5. Make sure that the option Show in editor is selected.

6. Click OK.

A new TTCN document is created in the source directory. At the 
same time, a TTCN icon is created in the Organizer. After that, the 
TTCN suite is started. The TTCN Browser will show the new test 
suite in collapsed format.

Figure 11: Add New dialog
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 Creating a TTCN Test Suite Document
Figure 12: The TTCN suite is started and the Browser displays the test suite
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Using the Browser

What You Will Learn
• To expand and collapse nodes
• To build a test suite

Expanding and Collapsing Nodes
The Browser displays the test suite in a collapsed format, which is indi-
cated by plus signs in front of the nodes. You expand and collapse the 
nodes the same way that you expand and collapse directory levels in the 
Windows Explorer.

Some nodes are not marked with plus or minus signs. Those node are 
tree nodes without children. The node Test Cases in Figure 13 is an ex-
ample of this. Such nodes represent the static (structural) parts of the 
test suite that cannot be opened or edited.

Figure 13: The Dynamic Part has been expanded
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 Using the Browser
Building a Test Suite
You are now going to add a TTCN table to your test suite. 

To add a PCO type:

1. Expand the Declarations Part.

To be able to see the entire test suite, you may also have to enlarge 
the Browser window.

2. Select the PCO Type Declarations node.

3. Select Add in from the Edit menu.

A PCO Type with the temporary name NoName is added in the PCO 
Type Declarations list. The table icon looks like a small graphical 
table, which means that it can be opened and edited.

4. Rename the PCO type NoName by clicking on it when it is selected, 
that is, it becomes highlighted. Name the PCO type LOWER_PCO.

Note that the new table is marked with a question mark to indicate 
that it has not yet been analyzed.

Figure 14: The test suite when a PCO Type has been added
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5. You should also add the following items:

– A TTCN PCO called L 
(Declarations Part > PCO Declarations)

– A TTCN PDU called SEND 
(Declarations Part > PDU Type Definitions > TTCN PDU Type 
Definitions)

– A TTCN PDU called RECEIVE 
(Declarations Part > PDU Type Definitions > TTCN PDU Type 
Definitions)

You can also copy and paste SEND and change the name to RE-
CEIVE.

– A TTCN PDU constraint on the SEND PDU called S1
(Constraints Part > PDU Constraint Declarations > TTCN 
PDU Constraint Declarations)

– A TTCN PDU constraint on the RECEIVE PDU called R1
(Constraints Part > PDU Constraint Declarations > TTCN 
PDU Constraint Declarations)

You can also copy and paste S1 and change the name to R1.

– A test case called TEST_CASE_1
(Dynamic Part > Test Cases)

– A test step called TEST_STEP_1
Dynamic Part > Test Step Library)
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 Using the Browser
The next step is to edit the tables that you just added.

Figure 15: The test suite when the tables have been added
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Using the Table Editor

What You Will Learn
• To open the Table Editor
• To resize the window parts
• To edit the contents of a table

Opening the Table Editor
The Table Editor is opened when you double-click a table icon in the 
Browser:

• Double-click the test case table TEST_CASE_1.

The test case table is opened in the Table Editor.

Resizing the Table
As you can see, the Table Editor window is divided into three parts: the 
header, the body and the footer. These parts can be resized and hidden.

• Drag the horizontal bars that separates the table parts to change the 
relative size.

• Drag a row separator in the left most column to change the height of 
a row.

• Drag a column separator in a header of the body part of the table to 
change the column width.

Figure 16: The test case TEST_CASE_1 which has not yet been edited

The header

The body

The footer
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 Using the Table Editor
Editing the Test Case Table
As you can see, TEST_CASE_1, or any other table, consists of fields 
where text may be inserted and edited. This is what you are going to do 
now:

1. Click in the Purpose field and type some text, for example:
This is an example test case for the TTCN suite tuto-
rial.

2. Type some text in the Description field: Example test case.

– Instead of clicking the mouse to set the input focus, you can 
press <down arrow> until the cursor has reached the Descrip-
tion field.

It is also possible to type text in the other fields but you do not have 
to do that in this tutorial. Note that the Group field is not editable. 
The contents of this field is always kept updated from the Browser 
structure.

3. Select Insert New Row After from the Edit menu.

– You can also press <Ins> or <Insert>.

A new empty line is added to the body of the table. Note that the line 
is automatically numbered.

4. Type L! SENT in the Behaviour description field of the new line.

5. Type S1 in the Constraints Ref field.

6. Press <Ins> or <Insert> to add another new line.

7. Type +TEST_STEP_1 in the Behaviour Description field of row 2

Note that the text is automatically indented.

Note:

The misspelling of “SEND” is intentional!
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When you have edited TEST_CASE_1, you should close the table.

Completing the Test Suite
You should now edit the other tables that you have already added to the 
test suite. Use the tables in the following figures as models.

1. Edit the tables in the Declarations Part of the test suite, that is the 
PCO type LOWER_PCO, the PCO called L and the PDUs called 
SEND and RECEIVE:

Figure 17: The test case TEST_CASE_1 when it has been edited.

The misspelling of “SEND” is intentional.

Figure 18: The PCO type LOWER_PCO

Figure 19: The PCO L
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 Using the Table Editor
Since the contents of SEND and RECEIVE are identical, you can 
copy the text and rows from SEND and paste them in RECEIVE:

– Select text in the usual way with the mouse.

– Select an entire row in the body of a table by clicking the left 
most field.

When you are going to paste, note the following:

– Text can only be pasted in text edit mode, that is, when a field 
contains a text pointer.

– A body row can only be pasted when a body row is selected or 
when a body field is highlighted.

Figure 20: The PDU SEND

Note:

This means that there are two paste buffers: one for plain text and 
one for body rows.
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2. Edit the tables in the Constraints Part, that is the PDU constraints 
called S1 and R1:

Figure 21: The PDU RECEIVE

Figure 22: The PDU constraint S1

Figure 23: The PDU constraint R1
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 Using the Table Editor
3. Edit the test step called TEST_STEP_1 in the Dynamic Part:

When you add row 2 it is automatically indented, however, in this 
case it should not be. To decrease the indention, put the cursor in 
row 2 and then either:

– Press <Alt+-> (<Alt> and the minus key).
– Click the minus indention quick-button.
– Select Edit > Decrease Indention Level.

4. Close all tables when you have finished editing.

5. Save the test suite by selecting Save in the File menu.

Figure 24: The test step TEST_STEP_1
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Analyzing the Test Suite

What You Will Learn
• To analyze a test suite
• To find errors

Analyzing the Test Suite
You are now going to analyze the test suite:

1. Select Analyze Suite from the Build menu.

– You can also select the top node in the Browser and then select 
Analyze. Analyze only works on selected parts of a test suite (in-
cluding sub-trees) so in this case it will have the same effect as 
Analyze Suite.)

The Analyzer/TTCN to C Compiler Settings dialog is opened. You 
do not have to change the settings in this tutorial.

Figure 25: The Analyzer/TTCN to C Compiler Settings dialog
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 Analyzing the Test Suite
Note that if you analyze the test suite again by using a quick-button 
or a shortcut, the same options will be used but the dialog will not 
be displayed.

2. Click OK.

If you have edited the test suite as described, the TTCN suite Log 
Manager is opened with a textual log that should show a single error 
message:

The log text means that there is an error in line 1 of the behaviour 
description of the test case dynamic behaviour table called 
TEST_CASE_1.

Also note that the parent nodes to the erroneous table are marked 
with a red arrow and the table is marked with a red cross in the 
Browser.

Finding and Correcting the Error
To find the erroneous table, you use the popup menu:

1. In the Log Manager, click the table identifier, that is, the name of 
the table: TEST_CASE_1.

2. <Ctrl>-right-click the name of the table again.

A popup menu is opened.

Figure 26: The TTCN suite Log Manager window showing one error
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3. Select the top command in the popup menu: Test Case Name: 
TEST_CASE_1.

The Table Editor window is opened, displaying the TEST_CASE_1 
table. Note that the error is marked in red, in this case L! SENT in 
the Behaviour Description column.

You should now correct the error and analyze again:

1. Correct the error, i.e. change SENT to SEND.

2. Analyze the test suite again. You can do this while having the Table 
Editor window still opened since the Analyzer works on any level 
of the test suite.

You will now have a small test suite that is syntactically correct. 
This means that the red markings will disappear.

Figure 27: Finding a table by using the popup menu in the Log Manager
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 Creating TTCN Tables in Other Ways
Creating TTCN Tables in Other Ways
The methods described below make it faster and more efficient to create 
TTCN tables. They also avoid annoying spelling errors and reduces the 
amount of text that needs to be typed.

What You Will Learn
• To create a table by copying and pasting.
• To create a table by using the Data Dictionary.
• To delete a table.

Copying and Pasting
You are now going to practice another way of creating a TTCN table, 
namely by copying and pasting it.

1. Copy the PDU called SEND in the Browser.

2. Select S1 and then paste the table you have copied.

The SEND table is pasted before S1.

Editing the New Table

1. Open the new SEND table.

The Table Editor window is opened displaying the table. As you can 
see, the PDU Type field and the Field names are filled in. Now you 
just have to change the name and insert values in Field_1 and 
Field_2.

2. Type a new name in the Constraint Name field: S2.

3. Give Field_1 the value 3 and Field_2 the value TRUE in the Field 
Value column.

4. Analyze the entire test suite as described in “Analyzing the Test 
Suite” on page 54.
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Using the Data Dictionary
You can use the Data Dictionary to interactively build behaviour lines 
in behaviour tables. In the Data Dictionary dialog, you can compose 
sends, receives, timeouts and attachments, and at the same time see how 
it turns out in the dialog. 

In this simple example, you will use the Data Dictionary to create a new 
test case with the same contents as TEST_CASE_1, and as a compari-
son you may have that table opened too:

1. Create a new test case and open it.

2. Name the test case TEST_CASE_2.

3. Open the Data Dictionary from the View menu.

Figure 28: The Data Dictionary dialog
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4. In the Send/Receive tab in the dialog, make the following settings:

– Select the PCO L.

– Select the ! (exclamation mark) radio button, which means that 
you will add a send statement.

– Select the type SEND.

– Select the constraint S1.

– No verdict should be selected.

The Behaviour Line, the Constraint and the Verdict fields show the 
contents of the behaviour line that is inserted in the table.

5. Click Apply.

The behaviour line you have composed is inserted in the table.

6. In the Attachment tab, select TEST_STEP_1. 

The Behavior Line will read +TEST_STEP_1.

7. Click the Apply button.

The behaviour line is inserted and TEST_CASE_2 should now be 
identical to TEST_CASE_1.

8. Close the Data Dictionary dialog.

Deleting the Tables
You will not need the newly created tables in the rest of this tutorial. 
You should therefore delete them:

1. Select S2 and TEST_CASE_2 in the Browser.

2. Select Delete from the Edit menu or press the <Delete> key.

The tables are deleted.
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Exporting a Test Suite

What You Will Learn
• To save the test suite as TTCN-MP
• To generate the test suite overview
• To save the test suite as HTML

Saving a Test Suite to MP Format and 
Generating the Overview
You should now convert the test suite to TTCN-MP format. However, 
before the actual conversion, the test suite overview has to be generated. 
How to do this will also be described below.

1. Select the top node of the test suite in the Browser.

2. Select Save As from the File menu.

Since the test suite overview has not been generated before, it has to 
be done now. A dialog is opened where you can confirm this oper-
ation.

3. Click Yes in the confirmation dialog.

Since the test suite you have created is small, the generation will not 
take long. Also, once it has been generated, it will be updated auto-
matically.

A file dialog is opened.

4. Specify where the file is to be saved, ensure that you save as type 
TTCN-MP and give the file a name (example).

The test suite will now be renamed to example.mp.

A TTCN-MP file can be opened like an ordinary .itex file.

Hint:

Optionally, you can use the Export to MP button for exporting the 
.itex file to MP, while keeping the .itex file open.
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 Exporting a Test Suite
Saving a Test Suite as HTML
To save the entire test suite, or selected parts of it, as HTML, you pro-
ceed as described in “Saving a Test Suite to MP Format and Generating 
the Overview” on page 60. But instead of TTCN-MP, select HTML as 
the file type. 

It is also possible to only export an opened table. To do this:

1. Open a table.

2. Select Generate HTML from the pop-up menu in the table.

3. Select a name of the file and where it should be saved.

An HTML document cannot be opened in the TTCN suite again, but 
you can view it in an HTML browser.
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Printing the Test Suite
You should by now have a test suite that is syntactically correct. 

If you have saved the test suite as MP, as described earlier, the test suite 
overview should also have been generated and it does not have to be 
done again. The overview will be automatically updated as soon as you 
make any changes in the test suite after the generation.

If you did not save the test suite as MP, you will have to confirm the up-
dating of the overview before printing is possible.

You can print a test suite both from the TTCN suite and the Organizer. 
The main differences are that in the TTCN suite there is a print preview, 
and in the Organizer, you can print several test suites at the same time.

Printing from the TTCN Suite
To print from the TTCN suite:

1. Ensure that the Browser window is active.

2. Select Print from the File menu.

The Print dialog is opened.

3. If necessary, change some settings.

4. Click OK.

The test suite is printed.

Printing from the Organizer
To print from the Organizer:

1. Select the TTCN document icon in the Organizer.

2. Select Print from the File menu.

The Print TTCN dialog is opened.

3. If necessary, change some settings.

4. Click Print.

The test suite is printed.
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 So Far...
So Far...
You should now have learned how to create a test suite and how to edit 
it in the Browser. You have also learned how to create and edit tables 
and how to work with the Table Editor. Other things you should have 
learned is how to analyze the test suite, how to find errors and how to 
save as MP and HTML.

By practicing this tutorial you have probably not achieved any knowl-
edge about TTCN. If you want to know more about the basics of TTCN 
you may read the TTCN Suite Methodology Guidelines. That volume 
is, however, not a tutorial on TTCN.

The following tutorial is chapter 6, Tutorial: TTCN-SDL Co-Simulator 
(Windows). Before you start practising that, you should know how to 
use the SDL Simulator. A tutorial on that can be found in chapter 4, Tu-
torial: The SDL Simulator, in the SDL Suite Getting Started.
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